You cannot join a Windows Vista x64 Edition-based client computer to a Windows domain on which ISA Server 2004 is configured as a firewall (917903)



The information in this article applies to:

  • Microsoft Internet Security and Acceleration Server 2004, Enterprise Edition
  • Microsoft Internet Security and Acceleration Server 2004, Standard Edition
  • Microsoft Windows Vista Beta 2 English (United States)

Beta Information

This article discusses a Beta release of a Microsoft product. The information in this article is provided as-is and is subject to change without notice.

No formal product support is available from Microsoft for this Beta product. For information about how to obtain support for a Beta release, see the documentation that is included with the Beta product files, or check the Web location where you downloaded the release.

SYMPTOMS

Consider the following scenario. You have a Windows domain on which Microsoft Internet Security and Acceleration (ISA) Server 2004 is configured as a firewall. You try to add to the domain a client computer that is running the beta version of Microsoft Windows Vista x64 Edition. However, you receive an "RPC Server unavailable" error message on the Windows Vista x64 Edition-based client computer. Additionally, the computer is not added to the domain.

Note This problem occurs primarily in a Microsoft Windows Small Business Server 2003 (Windows SBS) domain.

CAUSE

This problem occurs because Windows Vista x64 Edition-based client computers add a third context element structure to a remote procedure call (RPC) bind call. However, the ISA Server RPC application filter drops this bind call as an incorrect RPC bind packet. Therefore, the Netlogon call fails.

RESOLUTION

How to obtain the hotfix

This issue is fixed in the ISA Server 2004 Hotfix Package dated April 24, 2006. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

917902 Description of the ISA Server 2004 hotfix package: April 24, 2006

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MajorLast Reviewed:7/10/2006
Keywords:kbQFE kbprb KB917903 kbAudITPRO