The BizTalk Server process closes unexpectedly in BizTalk Server 2006 (917846)



The information in this article applies to:

  • Microsoft BizTalk Server 2006 Standard Edition
  • Microsoft BizTalk Server 2006 Developer Edition
  • Microsoft BizTalk Server 2006 Enterprise Edition

SYMPTOMS

In Microsoft BizTalk Server 2006, the BizTalk Server process (Btsntsvc.exe) may close unexpectedly. You may not receive any errors in the Application event log.

CAUSE

This issue occurs if all the following conditions are true:
  • The BizTalk Server process is configured as the host for a file send handler.
  • The file send handler is configured in a send port to write to a UNC share.
  • The UNC share has insufficient disk space.
In this scenario, the BizTalk Server process closes if the disk is full. The System.IO.FileStream object does not catch all the exceptions in the Finalize() method. Therefore, the BizTalk Server process closes.

RESOLUTION

To resolve this issue, free disk space on the UNC share. To prevent the BizTalk Server process from closing unexpectedly, follow these steps:
  1. Click Start, click Run, type notepad, and then click OK.
  2. Click File, and then click Open.
  3. In the Files of type list, click All Files.
  4. Locate and then click the BTSNTSvc.exe.config file or the BTSNTSvc64.exe.config file, and then click Open.

    Note By default, the BTSNTSvc.exe.config file and the BTSNTSvc64.exe.config file are located in the drive:\Program Files\Microsoft BizTalk Server 2006 folder. drive is the hard disk where BizTalk Server 2006 is installed.
  5. In Notepad, manually add the following code to the file.
    <legacyUnhandledExceptionPolicy enabled="true" />
    The file may resemble the following sample code.
    <runtime>
    <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
    <probing privatePath="BizTalk Assemblies;Developer Tools;Tracking;Tracking\interop" />
    </assemblyBinding>
    
    <legacyUnhandledExceptionPolicy enabled="true" />
    </runtime>
    
  6. On the File menu, click Save.
  7. On the File menu, click Exit.
  8. Restart the BizTalk Server process.

Modification Type:MajorLast Reviewed:5/5/2006
Keywords:kbBTSAdapters kbBTS kbtshoot kbcode kbprb KB917846 kbAudDeveloper kbAudITPRO