HTML messages that contain many font tags or span tags are not forwarded by Exchange Server 2003 after you configure an e-mail forwarding rule in Outlook (917683)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition

SYMPTOMS

Consider the following scenario:
  • Microsoft Outlook is connected to a mail server that is running Microsoft Exchange Server 2003.
  • You configure an automatic forwarding rule in Outlook to forward your e-mail messages to another location.
In this scenario, you notice that some of the e-mail messages that you receive in Outlook are not automatically forwarded to the location that you specified.

CAUSE

This problem may occur if the following conditions are true:
  • You receive an HTML message.
  • This HTML message contains many <FONT> tags or <SPAN> tags.
This problem occurs because Exchange Server is not able to successfully convert this message to RTF format to forward it. If the particular message contains many <FONT> tags or <SPAN> tags, the message may exceed the Exchange Server recursion limit for the message conversion operation. In this situation, Exchange Server disables the e-mail forwarding rule that you configured in Outlook.

WORKAROUND

To work around this problem, modify the Outlook e-mail forwarding rule to use redirection instead of forwarding. To do this, follow these steps:
  1. Start Outlook.
  2. On the Tools menu, click Rules and Alerts.
  3. In the Rules and Alerts dialog box, click the E-mail Rules tab.
  4. In the Rule (applied in the order shown) list, click the e-mail forwarding rule, and then click Edit Rule Settings on the Change Rule menu.
  5. On the Which condition(s) do you want to check page, click Next.
  6. On the What do you want to do with the message page, click to clear the forward it to people or distribution list check box or the forward it to people or distribution list as an attachment check box depending on the forwarding rule that you are using.
  7. Click to select the redirect it to people or distribution list check box.
  8. In the Step 2. Edit the rule description area, click the people or distribution list link to specify the location to which you want to redirect the e-mail messages.
  9. Follow the remaining steps of the Rules Wizard to configure the e-mail redirection rule.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Exchange Server may not be configured to send this kind of HTML e-mail message over the Internet. Instead, this kind of HTML message may remain in the Exchange Server queue. To let Exchange Server send this kind of HTML message over the Internet, modify the Internet Message Formats settings in Exchange System Manager. To do this, follow these steps:
  1. Start Exchange System Manager.
  2. Expand Global Settings, right-click Internet Message Formats, point to New, and then click Domain.
  3. Click the General tab, type a descriptive name for this domain in the Name box, and then type the SMTP domain to which you want this policy to apply in the SMTP domain box. For example, type example.com.
  4. Click the Message Format tab.
  5. Under Message encoding click Mime, and then click Provide message body as HTML.
  6. Click OK.
For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:

821750 How to configure Internet e-mail message formats at the user and the domain levels in Exchange Server 2003

244150 Global setting for Internet message formats

821881 How to modify global settings in Exchange System Manager

For more information about a similar problem in Microsoft Exchange 2000 Server, click the following article number to view the article in the Microsoft Knowledge Base:

317005 Event 12800 error messages are logged when the Information Store is processing incoming messages from the Internet


Modification Type:MajorLast Reviewed:4/18/2006
Keywords:kbpending kbBug kbtshoot kbprb KB917683 kbAudITPRO kbAudEndUser