The sender display name may unexpectedly contain backslash characters in an e-mail message that is sent from an Exchange Server 2003 organization (917611)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange Server 2003 Enterprise Edition

SYMPTOMS

The sender display name may unexpectedly contain backslash characters in an e-mail message that is sent from a Microsoft Exchange Server 2003 organization. For example, the display name Administrator (HQ) may appear as Administrator \(HQ\).

CAUSE

This problem may occur when one of the following conditions is true:
  • A Microsoft e-mail client program or a third-party e-mail client program does not remove backslash characters that Exchange Server 2003 adds. Exchange Server 2003 adds backslash characters when the following conditions are true:
    • The server that is running Exchange Server 2003 has hotfix 886757 applied. This hotfix is described in the following article in the Microsoft Knowledge Base:

      886757 A sender's e-mail address appears to a recipient as two distinct addresses if the sender's display name contains a comma and extended characters in Exchange 2000 or in Exchange 2003

    • The RFC2047Compliant registry value is set to "0" as described in that article.
    • The display name contains non-US-ASCII characters.
    In this case, Exchange Server 2003 may encode the display name incorrectly. Therefore, backslash characters that Exchange Server 2003 adds to the display name may be displayed in a Microsoft e-mail client program or in a third-party e-mail client program.
  • A third-party e-mail client program does not remove backslash characters that Exchange Server 2003 adds to the display name to mask certain US-ASCII characters. This particular issue occurs only when the message is viewed in a third-party program.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Exchange Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To apply this hotfix, you must have Microsoft Exchange Server 2003 Service Pack 2 (SP2) installed.

Restart requirement

The following services are automatically stopped and then restarted when you apply this hotfix:
  • The Microsoft Exchange Information Store and all dependent services
  • Microsoft Internet Information Services (IIS) Admin Service and all dependent services

Hotfix replacement information

This hotfix does not replace any other hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Exmime.dll6.5.7651.34201,72806-Jul-200617:40x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about a similar issue, click the following article number to view the article in the Microsoft Knowledge Base:

886757 A sender's e-mail address appears to a recipient as two distinct addresses if the sender's display name contains a comma and extended characters in Exchange 2000 or in Exchange 2003

For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

817903 New naming schema for Exchange Server software update packages


Modification Type:MajorLast Reviewed:8/11/2006
Keywords:kbQFE kbfix kbBug kbhotfixserver kbpubtypekc KB917611 kbAudITPRO