Error message when you click Save on the Global Configuration page of the Sybari Enterprise Manager Web application: "Failed to update scheduler for job StatisticsJob, Access is denied" (917482)



The information in this article applies to:

  • Sybari Enterprise Manager 1.1, when used with:
    • Microsoft Exchange Server 2003 Enterprise Edition
    • Microsoft Exchange Server 2003 Standard Edition

SYMPTOMS

When you click Save after you modify settings on the Global Configuration page of the Sybari Enterprise Manager Web application, you receive the following error message:
Failed to update scheduler for job StatisticsJob, Access is denied.
You experience this problem if the following conditions are true:
  • Sybari Enterprise Manager build 1.1.64 is installed and configured.
  • You install Microsoft Antigen Enterprise Manager build 9.0.0995.0. Then, you let this program automatically remove Sybari Enterprise Manager.
  • You remove Microsoft Antigen Enterprise Manager. Then, you reinstall Sybari Enterprise Manager build 1.1.64.

CAUSE

This problem occurs because of a corrupted GUID in the DCOM Configuration permissions for the Sybari Enterprise Manager Scheduler service.

RESOLUTION

To resolve this problem, follow these steps:
  1. Start the Component Services Microsoft Management Console (MMC) snap-in. To do this, click Start, click Run, type %windir%\system32\com\comexp.msc, and then click OK.
  2. In the left pane, expand Component Services, expand Computers, expand My Computer, and then click DCOM Config.
  3. In the right pane, right-click SchedulerService, and then click Properties.
  4. Click the Security tab.
  5. In the Launch and Activation Permissions area of the Security tab, follow these steps:
    1. Click Edit.
    2. In the Group or user names list, click the corrupted GUID, and then click Remove.

      Note The corrupted GUID appears as a series of malformed user IDs. This GUID has a red question mark superimposed over it.
    3. Click OK to close the Launch Permission dialog box.
  6. In the Access Permissions area of the Security tab, follow these steps:
    1. Click Edit.
    2. In the Group or user names list, click the corrupted GUID, and then click Remove.
    3. Click OK to close the Access Permission dialog box.
  7. In the Configuration Permissions area of the Security tab, follow these steps:
    1. Click Edit.
    2. In the Group or user names list, click the corrupted GUID, and then click Remove.

      Note If a corrupted GUID does not appear in the Group or user names list, skip this step.
    3. Click OK to close the Change Configuration Permission dialog box.
  8. Click OK to close the SchedulerService Properties dialog box.
  9. In the left pane, right-click My Computer, and then click Refresh all components.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MajorLast Reviewed:4/18/2006
Keywords:kbnofix kbBug kbtshoot kbprb KB917482 kbAudITPRO