The Msimsp.exe utility may generate a stack error on a Windows Server 2003-based computer (917465)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition

SYMPTOMS

You use the Microsoft Windows Platform Software Development Kit (SDK) utility (Msimsp.exe) to generate a patch between two versions of an administrative installation on a Microsoft Windows Server 2003-based computer. When you do this, the Msimsp.exe utility may generate a stack error and immediately exit. The log file is incomplete and does not indicate the cause of the error.

CAUSE

This problem occurs when the original Microsoft Windows Installer packages have a file name or a directory name that exceeds the space that is reserved for an entry.

To identify the file, the full path of a file is used together with a GUID that is appended to the file. The path+file+GUID string is put in an internal table that represents the files that are to be installed. When the space for this table entry exceeds the reserved space, this problem may occur. The file path and the GUID are put into a table so that differences between the two installations can be compared.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Patchwiz.dll3.1.4000.2672165,88831-Mar-200605:13x86

WORKAROUND

To work around this problem, shorten the file path of the components. If the installation is already deployed, you must apply this hotfix to generate the patch.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbBug kbfix kbQFE kbhotfixserver kbpubtypekc KB917465 kbAudITPRO