FIX: Applications may not be able to allocate LU 6.2 sessions after you install Host Integration Server 2000 SP2 or you upgrade to Host Integration Server 2004 (917416)



The information in this article applies to:

  • Microsoft Host Integration Server 2004
  • Microsoft Host Integration Server 2000 SP2

SYMPTOMS

After you install Microsoft Host Integration Server 2000 Service Pack 2 (SP2) or you upgrade to Microsoft Host Integration Server 2004, Advanced Program-to-Program Communications (APPC) or Common Programming Interface for Communications (CPI-C) applications may be unable to allocate LU 6.2 sessions.

This problem only occurs if the following conditions are true:
  • The Host Integration Server systems use dependent APPC LUs to communicate with the host system.
  • Duplicate Remote APPC LUs are defined on multiple host connections under a specific SNA Server service. In this case, the duplicate Remote APPC LUs have the same fully qualified LU name.
The exact symptoms that end users of the APPC or CPI-C applications experience may vary depending on the application. If the underlying APPC ALLOCATE verb sets the return control parameter set to AP_WHEN_SESSION_ALLOCATED, the application may appear to stop responding when the problem occurs.

If the application has been designed to cancel outstanding ALLOCATE or CMALLC verbs that have not completed after some time has passed, the application cancels the ALLOCATE verb and returns an application-specific error message.

CAUSE

This problem occurs because an issue was introduced by the hotfix that is described in Microsoft Knowledge Base article 837314. For more information about this hotfix, click the following article number to view the article in the Microsoft Knowledge Base:

837314 Dependent LU6.2 sessions may use the wrong LUs when multiple Remote LUs have the same LU alias

RESOLUTION

Host Integration Server 2000

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Host Integration Server 2000 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatformSP requirement
Snaservr.exe5.0.0.2094471,31206-Apr-200622:36x86SP3
Trcservr.exe5.0.0.20941,057,04006-Apr-200622:36x86SP3
Note Because of file dependencies, the most recent hotfix that contains these files may also contain additional files.

Host Integration Server 2004

No hotfix is currently available for Host Integration Server 2004.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbfix kbbug kbQFE kbhotfixserver kbpubtypekc KB917416 kbAudDeveloper