Users cannot move a file from one folder to another folder when they connect to a shared folder in Windows Server 2003 R2 (917315)



The information in this article applies to:

  • Microsoft Windows Server 2003 R2 Enterprise Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003 R2 Datacenter Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Enterprise x64 Edition
  • Microsoft Windows Server 2003 R2 Datacenter x64 Edition
  • Microsoft Windows Small Business Server 2003 R2 Standard Edition
  • Microsoft Windows Small Business Server 2003 R2 Premium Edition

SYMPTOMS

Consider the following scenario:
  • You create root directories and assign them to users in a Microsoft Windows Server 2003-based domain.
  • You create junction points from a shared folder to the corresponding user's folder on the mounted volume.
  • You use File System Resource Manager to create a disk quota for each user.
In this scenario, users cannot move a file from one folder to another folder when they connect to the shared folder by using a Universal Naming Convention (UNC) path.

Note This problem does not occur if disk quotas are not created for the users.

CAUSE

This problem occurs because of an issue with the Filter Manager that manages the implementation and the deployment of file system filters.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To install this hotfix, the computer must be running Windows Server 2003 R2.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.Windows Server 2003 R2, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Fltmgr.sys5.2.3790.2691129,53628-Apr-200601:26x86
Windows Server 2003 R2, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Fltmgr.sys5.2.3790.2691226,81628-Apr-200604:27x64
Windows Server 2003 R2, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Fltmgr.sys5.2.3790.2691470,01628-Apr-200604:28IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the description of the terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:8/21/2006
Keywords:kbWinServ2003preSP2fix kbBug kbfix kbQFE kbhotfixserver kbpubtypekc KB917315 kbAudITPRO