The File Server Resource Manager reports that the jobs are not responding when you run many jobs on Windows Server 2003 R2 (917314)



The information in this article applies to:

  • Microsoft Windows Server 2003 R2 Enterprise x64 Edition
  • Microsoft Windows Server 2003 R2 Enterprise Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003 R2 Standard x64 Edition

SYMPTOMS

When you run a single job on Microsoft Windows Server 2003 R2, it runs correctly. However, the File Server Resource Manager (FSRM) reports that the jobs are not responding when you select all the jobs. This condition depends on the number of shares that are available on the Windows Server 2003 R2 server.

CAUSE

This problem occurs when you have many shares that report to FSRM. The FSRM takes a long time to calculate and to manage the quantity and the type of data that are stored on the server.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.Windows Server 2003 R2, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Srmsvc.dll5.2.3790.26903,381,24826-Apr-200607:06x64
Updspapi.dll6.2.29.0462,04826-Apr-200607:08x64
Windows Server 2003 R2, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Srmsvc.dll5.2.3790.26901,593,34426-Apr-200619:23x86SP1SP1QFE
Updspapi.dll6.2.29.0371,42412-Oct-200523:15x86NoneNot Applicable
Windows Server 2003 R2, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Srmsvc.dll5.2.3790.26906,165,50426-Apr-200607:07IA-64
Updspapi.dll6.2.29.0638,68826-Apr-200607:08IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

In Windows Server 2003 R2, a change was made in the way that you call an API to enumerate the shares

Technical support for x64-based versions of Microsoft Windows

If your hardware came with a Microsoft Windows x64 edition already installed, your hardware manufacturer provides technical support and assistance for the Windows x64 edition. In this case, your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation by using unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with a Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware. If you purchased a Windows x64 edition such as a Microsoft Windows Server 2003 x64 edition separately, contact Microsoft for technical support.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about x64-based versions of Microsoft Windows Server 2003, visit the following Microsoft Web site: .

Modification Type:MajorLast Reviewed:7/31/2006
Keywords:kbWinServ2003preSP2fix kbBug kbfix kbQFE kbhotfixserver kbpubtypekc KB917314 kbAudITPRO