The Management Console snap-in no longer runs after you remove all Communicator Web Access updates (917246)



The information in this article applies to:

  • Microsoft Office Communicator Web Access

SYMPTOMS

After you remove all Microsoft Office Communicator Web Access updates from the server that is running Communicator Web Access, the Management Console snap-in no longer runs.

For example, you have no updates installed on Communicator Web Access. You then install the update that is described in the following article in the Microsoft Knowledge Base:

915066 Description of the update for Communicator Web Access: March 31, 2006

If you remove this update and then try to run the Management Console snap-in, the snap-in will not run.

CAUSE

This problem occurs because the Management Console snap-in is unregistered after the last update for Communicator Web Access is removed.

Notes
  • This problem will not occur if no updates have been installed on Communicator Web Access.
  • This problem will not occur if at least one update remains installed on Communicator Web Access.

WORKAROUND

To work around this problem, reregister the Management Console snap-in component (Cwasnap.dll). To do this, follow these steps:
  1. Click Start, click Run, type cmd in the Open box, and then click OK.
  2. Type cd /d "C:\Program Files\Microsoft Office Communicator Web Access\Admin", and then press ENTER.

    Note The installation directory for Communicator Web Access may be different on your computer.
  3. Type regsver32 cwasnap.dll, and then press ENTER.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:4/1/2006
Keywords:kbprb kbtshoot kbsetup kbExpertiseInter kbmsccsearch kbpubtypekc KB917246 kbAudITPRO