Groove does not synchronize with other computers that run an account after you restore the account from an account file (917206)



The information in this article applies to:

  • Groove Virtual Office 3.1 File Sharing Edition
  • Groove Virtual Office 3.1 Professional Edition
  • Groove Virtual Office 3.1 Project Edition
  • Groove Virtual Office 3.1 Trial Edition
  • Groove Virtual Office 3.0 File Sharing Edition
  • Groove Virtual Office 3.0 Professional Edition
  • Groove Virtual Office 3.0 Project Edition
  • Groove Virtual Office 3.0 Trial Edition
  • Groove Workspace 2.5 Preview Edition
  • Groove Workspace 2.5 Professional Edition
  • Groove Workspace 2.5 Project Edition
  • Groove Workspace 2.5 Standard Edition

SYMPTOMS

Consider the following scenario in Groove Virtual Office or in Groove Workspace:
  • You import a Groove account on other computers.
  • You delete the account from the first computer.
  • You use an account file that was created before you imported the account on the other computers to restore the account on the first computer.
In this scenario, the restored account on the first computer does not know about the other computers. Additionally, the first computer does not synchronize with the other computers.

CAUSE

When you export a Groove account to a file, the file contains information about the exporting computer and about any other computers that are known to run that account. When that account is imported, it will contact the other computers to let them know that it is a new computer for the account. Groove cannot discover other computers that are not specified in an account file.

RESOLUTION

If you want to import a Groove account on other computers, you must save the account file again after you import it on each computer. Then, use the new account file that includes information about the new computer to import the account on the next computer.

The following scenario describes how this problem occurs and how to resolve it:
  1. The account exists on one computer, PC1.
  2. On PC1, you export the account to a file. That file contains information about PC1.
  3. You import the account file on another computer, PC2. PC2 now knows about PC1.
  4. PC2 sends an update. PC1 now knows about PC2.
  5. You import the same account file on a third computer, PC3. PC3 now knows about PC1.
  6. PC3 sends an update. PC1 now knows about PC3 and PC2. However, PC3 does not know about PC2. Additionally, PC2 does not know about PC3.
To resolve this problem, follow these steps:
  1. On PC3, save any information that is unique to Groove on that computer. Then, delete the account.
  2. Exit and then restart Groove two times to process all the actions that are required for the account deletion.
  3. On PC1, click Preferences on the Options menu, and then click Account. Confirm that PC3 is no longer in the Computers list.
  4. On PC1, create a new account file. The file contains information about PC1 and PC2.
  5. On PC3, import the new account file. PC3 now knows about PC2 and PC1. Additionally, PC3 sends updates so that PC2 and PC1 know about PC3.
Note If the account is not deleted from Groove on PC3 but is lost because of file deletions or hardware failure, an old version of PC3 still appears in the Computers list for the Groove account. Additionally, PC3 becomes unsynchronized. This is an expected behavior. You should delete the invalid computer listing from the Multiple Computers list as soon as possible. This list is on the Account tab in the Preferences dialog box in Groove Virtual Office 3.x. The list is on the My Computers page in Groove Workspace 2.x. If you leave an unsynchronized computer that is associated with the account, you may experience additional problems.

In Groove Virtual Office 3.x, you can delete the invalid computer immediately. In Groove Workspace 2.x, you must wait until the listing displays a synchronization message.

Note Do not delete the valid computer that has the same name. To make sure that you do not delete the valid computer that has the same name, delete the entry from the computer that you are currently using. When you click the computer that you are currently using, the Remove Computer option is unavailable.

Modification Type:MajorLast Reviewed:6/20/2006
Keywords:kbprb kbExpertiseInter kbtshoot KB917206 kbAudKnowledgeWorker