The proxy management points of the secondary site in Systems Management Server 2003 cannot access SQL Server after you move SQL Server to new hardware (916904)



The information in this article applies to:

  • Microsoft Systems Management Server 2003

SYMPTOMS

After you move the Microsoft Systems Management Server (SMS) 2003 central primary site database to new hardware, the secondary site cannot access SQL Server. This behavior occurs because the secondary site proxy management points cannot connect to the primary site database.

Additionally, the following error messages are logged on the log files in the secondary sites.

Mpcontrol.log
Http verification .sms_aut failed with no header recieved
Failed to receive http response. Error 12152
Http verification .sms_aut failed with no header recieved
Ccmexec.log
Request failed: 401 Access Denied
Request failed: 401 Access Denied
Could not load logging configuration for component PolicyAgent_ReplyAssignments. Using default values.
Mp_Getauth.log
CMPDBConnection::Init(): IDBInitialize::Initialize() failed with 0x80040e4d
CMPDBConnection::Init(): IDBInitialize::Initialize() failed with 0x80004005
CMPDBConnection::Init(): IDBInitialize::Initialize() failed with 0x80040e4d
CMPDBConnection::Init(): IDBInitialize::Initialize() failed with 0x80040e4d
Mp_Policy.log
CPolicyManagerHandler::HandleMessage(): SetComplete(DISCARD) called.
CMPDBConnection::Init(): IDBInitialize::Initialize() failed with 0x80040e4d
CPolicyManagerHandler::HandleMessage(): SetComplete(DISCARD) called.
CMPDBConnection::Init(): IDBInitialize::Initialize() failed with 0x80004005
CPolicyManagerHandler::HandleMessage(): SetComplete(DISCARD) called.
In some cases, the following error message is logged in the Mp_Getauth.log:
CMPDBConnection::ExecuteSQL(): ICommandText::Execute() failed with 0x80040E09

CAUSE

This problem occurs because the security identifier (SID) of the SMS_SitetoSQLConnection group is changed during the restore process of the SQL Server database. However, the SID of the SMS_SitetoSQLConnection group user in the database is not changed. SQL Server does not allow for authentication of the Site System Database account, the SMS_SQL_RX_sitecode or the alternate user account in Standard security, or the site system computer account in Advanced security.

RESOLUTION

To resolve this problem, remove and then add the SMS_SiteSystemtoSQLConnection_sitecode group in the SQL Server Enterprise Manager logins. To do this, follow these steps:
  1. Open SQL Server Enterprise Manager.
  2. In the SQL Enterprise Manager snap-in, expand Microsoft SQL Servers, expand SQL Server Group, expand ServerName, expand Databases, expand SMS Database, and then click Users.
  3. Right-click SMS_SiteSystemToSQLConnection_sitecode in the details pane, and then click delete.
  4. Expand Security, right-click Logins, and then click New Login.
  5. On the General tab, type SQLServer\SMS_SiteSystemToSQLConnection_sitecode in the Name box, and then click the Database Access tab.
  6. Click to select the Permit check box for the SMS_site code database, and then click to select the public database role check box.
  7. Click OK
  8. In the SQL Server Enterprise Manager view pane, click SMS DatabaseUsers.
  9. Right-click the SMS_SiteSystemToSQLConnection_sitecode user in the details pane, click Properties, and then click Permissions.
  10. In the Object list, click to select the appropriate check box for each permission in the following table.
    TablePermission
    DMP_GetDiscoveryTranslationEXEC
    DMP_GetFqdnsEXEC
    DMP_GetHinvTranslationsEXEC
    DMP_GetMachinePoliciesEXEC
    DMP_GetPackageVersionEXEC
    DMP_GetSettingsEXEC
    DMP_GetSoftwareDistBodyEXEC
    DMP_GetSoftwareDistIDsEXEC
    MP_GetAllInventoryClasssesEXEC
    MP_GetContentDPInfoProtectedEXEC
    MP_GetContentDPInfoUnprotectedEXEC
    MP_GetHINVLastUpdateTime EXEC
    MP_GetInventoryClassPropertiesEXEC
    MP_GetListOfMPsInSiteEXEC
    MP_GetLocalSitesFromAssignedSiteEXEC
    MP_GetMPListForSiteEXEC
    MP_GetMPSitesFromAssignedSiteEXEC
    MP_GetMachinePolicyAssignmentsEXEC
    MP_GetPolicyBody EXEC
    MP_GetSiteInfoFromADSiteEXEC
    MP_GetSiteInfoFromIPAddressEXEC
    MP_GetUserAndUserGroupPolicyAssignmentsEXEC
    RoamingBoundaryADSite SELECT
    RoamingBoundaryIPRange SELECT
    RoamingBoundaryIPSubnetSELECT
    SiteBoundaryADSite SELECT
    SiteBoundaryIPSubnetSELECT
    SitesSELECT
    SysResListSELECT
    Sp_GetPublicKeySMSUIDEXEC
  11. Click OK two times to close the User Properties.

WORKAROUND

To work around this problem, use one of the following methods.

Note Use these methods as temporary solutions because both methods work around the SitetoSQLConnection group.

Method 1

Add the Site System Database account to the local administrators group of the parent site.

Method 2

  1. Open the SMS Administrator console
  2. Navigate to the secondary site that is the proxy management point.
  3. Click Site Systems, right-click the proxy management point server, and then click Properties.
  4. On the Management Point tab, change the Database drop-down list box from Use Parent Database to Use a Different Database.
  5. Type the applicable database server name, the database name, and then the authentication information.

    Note This can be either SQL Server or Windows authentication. We recommend that you use Windows authentication as the best practice. For more information, see the "SMS 2003 Security Best Practices" section in the Scenarios and Procedures for Microsoft Systems Management Server 2003: Security white paper. To view this white paper, visit the following Microsoft Web site:
  6. Click OK, and then close the SMS Administrator console.
  7. Restart the SMS Executive service on the secondary site server.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MajorLast Reviewed:5/29/2006
Keywords:kbSMSRecovery kbSMSMP kbtshoot kbExpertiseAdvanced kbfix kbBug kbprb KB916904 kbAudITPRO