A Windows Server 2003-based computer that uses a SAN boot configuration does not restart after you start the computer by using an alternative operating system (916860)



The information in this article applies to:

  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter Edition
  • Microsoft Windows Server 2003, Enterprise Edition

SYMPTOMS

Consider the following scenario:
  • A Microsoft Windows Server 2003-based computer uses a Storage Area Network (SAN) boot configuration.
  • The SAN is using a GUID partition table (GPT) disk for the boot disk.
  • The computer uses more that one host bus adapter (HBA) in a multipath configuration to communicate with the SAN disks.
  • The computer is restarted by using an alternative operating system such as Microsoft Windows Preinstallation Environment (Windows PE). The alternative operating system does not use a multipath driver that supports this multipath (MPIO) configuration. Therefore, instead of correctly displaying each SAN disk as a single unit, the operating system displays a copy of each SAN disk for each HBA interface.
In this scenario, when you try to restart the computer to Windows Server 2003, the computer does not restart.

CAUSE

The problem occurs because the alternative operating system changes the partition ID GUID on the GPT disks to avoid conflicts. In this scenario, the partition ID GUID on the boot disk is also changed. When you try to restart the computer to Windows Server 2003, the boot loader cannot find the system files because the boot disk now uses a different partition ID GUID. Therefore, Windows Server 2003 cannot start because the system files cannot be accessed.

RESOLUTION

To resolve this problem, you must integrate this hotfix into the Windows PE installation source files, and then rebuild Windows PE.

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Partmgr.sys5.2.3790.266425,08821-Mar-200602:33x86
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Partmgr.sys5.2.3790.266445,05621-Mar-200604:11x64
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Partmgr.sys5.2.3790.266483,45621-Mar-200604:11IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about booting from a Storage Area Network, click the following article number to view the article in the Microsoft Knowledge Base:

305547 Support for booting from a Storage Area Network (SAN)



For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Technical support for Windows x64 editions

Your hardware manufacturer provides technical support and assistance for Microsoft Windows x64 editions. Your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation with unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with your Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about Microsoft Windows Server 2003 x64 editions, visit the following Microsoft Web site:

Modification Type:MajorLast Reviewed:4/10/2006
Keywords:kbQFE kbHotfixServer kbExpertiseAdvanced KB916860 kbAudOEM