The Defrag.exe command-line tool stops responding (hangs) when you run the tool after you install Windows XP (916731)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition

SYMPTOMS

Consider the following scenario. You install Microsoft Windows XP on a computer, and then you run the Defrag. exe command-line tool to defragment the hard disk of the computer. However, the degragmentation process operation does not successfully finish. Then the Defrag.exe tool stops responding (hangs). Additionally, when you open Task Manager, you notice that the CPU usage for the Defrag.exe process increases to 100 percent and stays at that level.

CAUSE

This problem may occur if the Defrag.exe tool encounters a 0-byte attribute entry in the attribute list.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart Requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Dfrgntfs.exe5.1.2600.2869104,96017-Mar-200601:02x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the terminology that Microsoft uses to correct software after it is released, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:4/10/2006
Keywords:kbWinXPpreSP3fix kbHotfixServer kbfix kbbug kbmsccsearch kbpubtypekc KB916731 kbAudITPRO kbAudEndUser