You receive an error message when you try to remove or reinstall the Shared Computer Toolkit on a Windows XP Service Pack 2-based computer (916140)



The information in this article applies to:

  • Microsoft Windows XP Professional Service Pack 2 (SP2)
  • Microsoft Windows XP Home Edition Service Pack 2 (SP2)

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

When you delete the Microsoft Shared Computer Toolkit folder on a Microsoft Windows XP Service Pack 2 (SP2)-based computer, you cannot remove or reinstall the Shared Computer Toolkit. Additionally, when you try to remove or reinstall the Shared Computer Toolkit, you receive an error message that resembles the following:
There is a problem with this Windows Installer package. A script required for this install to complete could not be run. Contact your support personnel or package vendor.
Note The Shared Computer Toolkit is typically installed in the following folder:

System Drive:\Program Files\Microsoft Shared Computer Toolkit

CAUSE

This problem occurs because the Shared Computer Toolkit registry key is present on the computer.

RESOLUTION

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

To resolve this problem, delete the Shared Computer Toolkit registry key. To do this, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Installer\Products\C66E96CBED74E21478FD1D8B50A5A97F

  3. In the right pane, make sure that the ProductName registry entry contains the "Microsoft Shared Computer Toolkit" value under the Data column.
  4. On the Edit menu, click Delete, and then click Yes.
  5. Exit Registry Editor.

Modification Type:MajorLast Reviewed:4/28/2006
Keywords:kbtshoot KB916140 kbAudEndUser kbAudITPRO