FIX: A file grows significantly when the file is replicated through the File Replication service that has compression enabled in Windows 2000 Server (915985)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server

SYMPTOMS

Consider the following scenario:
  • A small file is compressed into the staging directory of a member server on a Microsoft Windows 2000 Server-based computer.
  • The File Replication service (FRS) replicates the file to another member server.
  • The file grows significantly regardless of the size of the original file.
  • This occurs after the file is decompressed on the target server.
In this scenario, the new file is unreadable because the file is corrupted.

CAUSE

This problem occurs because there is a problem in the compression/decompression algorithm.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next hotfix rollup package that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatformService branch
Ntdll.dll5.0.2195.7080484,11222-Mar-200608:47x86Not Applicable
Ntdll.dll5.0.2195.7080484,11222-Mar-200608:47x86UNIPROC

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:

816915 New file naming schema for Microsoft Windows software update packages

For more information about standard terminology in software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbBug kbfix kbQFE kbWin2000preSP5fix kbhotfixserver kbpubtypekc KB915985 kbAudITPRO kbAudGeneralUser