The duration value may be incorrect when you create an appointment activity record in Microsoft Dynamics CRM 3.0 (915916)



The information in this article applies to:

  • Microsoft Business Solutions CRM Sales for Outlook, when used with:
    • Microsoft CRM 3.0
  • Microsoft CRM 3.0

The hotfix that is discussed in this article is not available for the Chinese version of Microsoft Dynamics CRM or for the Japanese version of Microsoft Dynamics CRM.

SYMPTOMS

When you create an appointment activity record in Microsoft Dynamics CRM 3.0, the duration value for the activity may be incorrect. For example, consider the following scenario. You create an appointment activity record. In the Start Time box, you enter 7:00 AM on the current day. In the End Time box, you enter 8:00 AM on the following day. In this scenario, the duration value is calculated incorrectly as 1.04 days or 1498 minutes. The correct duration value is 1.0416666 days or 1500 minutes.

Note You can see this problem more clearly when the duration value is larger than one day.

CAUSE

This problem occurs because the duration value is converted to minutes and then is rounded to two decimal places.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Dynamics CRM 3.0 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Installation information

Install this update on computers that are running Microsoft CRM 3.0 Client or Microsoft CRM 3.0 Server.

Prerequisites

There are no prerequisites to apply this hotfix.

Removal information

To remove this hotfix, use the Add or Remove Programs item in Control Panel.

Restart requirement

If you are prompted, restart the computer after you install the hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Client
File nameFile sizeDateTime
Duration.htc9,74515-Mar-200608:16
Server
File nameFile sizeDateTime
Duration.htc9,74515-Mar-200608:15

Modification Type:MinorLast Reviewed:9/7/2006
Keywords:kbfix kbBug kbMBSMigrate kbQFE kbHotfixServer kbpubtypekc KB915916 kbAudEndUser