Error message when you use the Distribute Software Updates Wizard in SMS 2003 Service Pack 2: "Unknown error 0x80071017" (915801)



The information in this article applies to:

  • Microsoft Systems Management Server 2003 SP2

SYMPTOMS

You are using the Microsoft Systems Management Server (SMS) 2003 Distribute Software Updates Wizard to authorize updates from a SMS 2003 Service Pack 2-based computer. However, when you download the updates, you receive the following error message:
Error downloading file File Name.exe: Unknown error 0x80071017
This problem occurs if the following conditions are true:
  • The SMS site server is running on a Microsoft Windows 2000 Server-based computer or on a Microsoft Windows 2000 Advanced Server-based computer.
  • You are using the Distribute Software Updates Wizard to authorize updates for the SMS Inventory Tool for Hewlett-Packard (HP) Proliant and Integrity Updates.

CAUSE

When the Distribute Software Updates Wizard downloads updates for HP Proliant and Integrity Updates, the wizard tries to obtain the public key data from Windows Management Instrumentation (WMI). WMI returns a "0x80071017" error code (WBEM_INVALID_QUERY).

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Systems Management Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

You must install this hotfix on all computers that run the SMS Administrator console.

Prerequisites

There are no prerequisites.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Patchdownloader.dll2.50.4160.2101221,18401-Mar-200609:00x86
Sms2003-sp2-kb915801-x86-enu.exe2.50.4160.2102600,29610-Mar-200622:54x86
Sms_pdw.dll2.50.4160.2102626,68801-Mar-200609:05x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbExpertiseInter kbfix kbBug kbHotfixServer kbSMSFeaturePack kbSMSDistribution kbQFE kbpubtypekc KB915801 kbAudITPRO