Error message when you use the Copy Database Wizard in SQL Server 2005 to migrate the Microsoft Dynamics CRM 3.0 MSCRM database from SQL Server 2000: "Setting Source Connection (Error)" (915799)



The information in this article applies to:

  • Microsoft CRM 3.0

The hotfix that is discussed in this article is not available for the Chinese version of Microsoft Dynamics CRM or for the Japanese version of Microsoft Dynamics CRM.

SYMPTOMS

When you use the Copy Database Wizard in Microsoft SQL Server 2005 to migrate the Microsoft Dynamics CRM 3.0 MSCRM database from Microsoft SQL Server 2000, you receive the following error message in the Copy Database Wizard:
Setting Source Connection (Error)
Messages
. Error 0xc0202009: Source - Activity [1]: An OLE DB error has occurred. Error code: 0x80040E37. (SQL Server Import and Export Wizard)
. Error 0xc02020e8: Source - Activity [1]: Opening a rowset for "[Database Name_MSCRM].[dbo].[Activity]" failed. Check that the object exists in the database. (SQL Server Import and Export Wizard)
. Exception from HRESULT: 0xC02020E8 (Microsoft.SqlServer.DTSPipelineWrap)
Note The Database Name placeholder is a placeholder for the actual MSCRM database name.

When you then run the select * from Activity SQL command against the MSCRM database in SQL Query Analyzer to determine whether the object exists in the database, you receive the following error message:
Server: Msg 208, Level 16, State 1, Procedure Activity, Line 75
Invalid object name 'ActivityBase'.
Server: Msg 4413, Level 16, State 1, Line 1
Could not use view or function 'Activity' because of binding errors."

CAUSE

This problem occurs because a view references a table that does not exist. The table does not exist because the database did not correctly migrate.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Dynamics CRM 3.0 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Installation information

Install this update on computers that are running the server components of Microsoft CRM 3.0.

Prerequisites

There are no prerequisites for this hotfix.

Removal information

You cannot remove this hotfix.

Restart requirement

If you are prompted, restart the computer after you install the hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile sizeDateTime
Invoice status detail.rdl63,43611-May-200608:45
Invoice status.rdl31,78811-May-200608:45
Sales pipeline.rdl108,50711-May-200608:45
Service activity volume detail.rdl100,12411-May-200608:45
Service activity volume.rdl65,20011-May-200608:45

WORKAROUND

To work around this problem, use one of the following methods.

Method 1

Use the Detach Database command to remove the database from the instance of Microsoft SQL Server 2000. Then, use the Attach Database command to attach the database to the instance of Microsoft SQL 2005.

Method 2

  1. Back up the database in Microsoft SQL Server 2000.
  2. Install Microsoft SQL Server 2005.
  3. Restore the database in Microsoft SQL Server 2005.

MORE INFORMATION

For more information about the Copy Database Wizard in Microsoft SQL Server 2005, see the following topic in the SQL Server 2005 Books Online:

Upgrade to SQL Server 2005 with the Copy Database Wizard

For more information about the terminology that is used to describe Microsoft software updates, click the following article numbers to view the articles in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

887283 Microsoft Business Solutions CRM software hotfix and update package naming standards


Modification Type:MinorLast Reviewed:9/22/2006
Keywords:kbMBSupgrade kberrmsg kbBug kbHotfixServer kbQFE kbMBSMigrate kbpubtypekc KB915799 kbAudEndUser