Authorization Manager-enabled applications may not work after you install Windows Server 2003 Service Pack 1 (915786)



The information in this article applies to:

  • Microsoft Windows Server 2003 SP1

SYMPTOMS

Authorization Manager-enabled applications that use primary interoperability assemblies may not work after you install Microsoft Windows Server 2003 Service Pack 1.

CAUSE

This problem occurs because the primary interoperability assembly (Microsoft.interop.security.azroles.dll) is no longer registered in the global assembly cache after you install Windows Server 2003 SP1.

RESOLUTION

Update information

The following file is available for download from the Microsoft Download Center:

Update for Windows Server 2003 (KB915786): DownloadDownload the WindowsServer2003-KB915786-x86-ENU.exe package now.

Release Date: July 18, 2006

For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to obtain Microsoft support files from online services

Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.

Prerequisites

There are no prerequisites.

Restart requirement

You do not have to restart the computer after you apply this update.

Update replacement information

This update does not replace any other updates.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Azrlpia2.dll1.2.0.056,07219-Jan-200619:42x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbWinServ2003preSP2fix kbBug kbfix kbHotfixServer kbQFE kbpubtypekc KB915786 kbAudITPRO