Error message when you try to import a CSV file of domain members into Groove Enterprise Management Server: "File format is invalid" (915624)



The information in this article applies to:

  • Groove Enterprise Management Server 2.0
  • Groove Enterprise Management Server 2.1
  • Groove Enterprise Management Server 2.5
  • Groove Enterprise Management Server 3.0
  • Groove Enterprise Management Server 3.1

SYMPTOMS

When you try to import a comma separated value (CSV) file of domain members into Groove Enterprise Management Server, you may receive the following error message:
File format is invalid.

CAUSE

This problem occurs if a field contains a comma (,). For example, this problem occurs if "Jane Dow, PhD" appears in the Name field. A field cannot contain a comma because the comma is used to separate fields in a CSV file.

RESOLUTION

To resolve this problem, remove any commas that appear in fields, and then create the CSV file again.

MORE INFORMATION

If you import a CSV file that you created by using another method, you may receive the error message that is mentioned in the "Symptoms" section. For example, you may receive the error message in the following situations:
  • You export a file from a Microsoft Windows 2000 Active Directory server as Unicode text. To resolve this issue, export the file as Text instead.
  • You save a file from Microsoft Excel as Excel CSV. To resolve this issue, save the file as CSV (MS-DOS) instead.
In either of these situations, the file must contain at least six comma-terminated fields on each line. Excel does not add a comma to the end of the lines of a CSV file. Therefore, if you are using a file that was created in Excel, the file must have at least seven fields on each line. Or, you must open the file by using a text editor and add a comma to the end of each line.

For more information about CSV files, click the following article number to view the article in the Microsoft Knowledge Base:

914694 The last column of a CSV file may be lost when you import it into Groove Enterprise Management Server


Modification Type:MajorLast Reviewed:6/9/2006
Keywords:kbprb kbExpertiseInter kbtshoot KB915624 kbAudKnowledgeWorker