FIX: Error message in Microsoft TV IPTV 1.0: "At the moment TV is not available" (915582)



The information in this article applies to:

  • Microsoft TV IPTV 1.0

SYMPTOMS

In Microsoft TV IPTV 1.0, you may be unable to watch television. Additionally, you may experience all the following symptoms:
  • You receive the following error message on the television screen:
    At the moment TV is not available. Select restart to be able to establish new connection. If this problem persists please call xxx-xxxx
  • The Sqlservr.exe process consumes almost 100 percent of the CPU for several minutes.
  • On the SubscriberDB server, the tempdb and log files may grow larger than expected.
  • IPTV servers that have a client-facing role may experience time-out errors.
  • New set-top boxes are not provisioned, and you receive the following error message:
    The operation timed-out

CAUSE

This problem may occur when Microsoft SQL Server stored procedures are not optimized for performance for a growing number of set-top boxes.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must be running Microsoft TV IPTV 1.0.1 Service Pack 1 (SP1) to install this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other software updates.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Dbqfe120546.exe1.0.2250.26559192,51228-Feb-200622:45x86
_74565b2d_40f6_4b7d_a56a_8cb74b183784_sms.clientrights.dll1.0.2189.045,05621-Apr-200600:17x86

WORKAROUND

To work around this problem, create an index in SQL Server to avoid scan and sort operations. For example, create an index that resembles the following.
USE SubscriberDB
GO

CREATE INDEX [IX_sms_grant_PrincipalID_test] ON [dbo].[sms_grant]([principalId], [right], [conditionGroupId]) ON [PRIMARY]
GO

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbQFE kbprb kbpubtypekc KB915582 kbAudITPRO kbAudDeveloper