The "Modified" column shows the current date and time instead of the date and time that you configured in a custom program in SharePoint Portal Server 2003 (915489)



The information in this article applies to:

  • Microsoft Office SharePoint Portal Server 2003
  • Microsoft Windows SharePoint Services

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

Consider the following scenario. You create a discussion board in Microsoft Office SharePoint Portal Server 2003. You run a custom program that adds discussion items to the discussion board programmatically. The custom program also configures the date and time that appear in the Modified column for the discussion items.

However, after you run the custom program, the Modified column for the discussion items shows the current date and time instead of the date and time that you configured in the custom program.

CAUSE

This issue occurs when the discussion board is located in a subarea of the portal site. For example, you do not experience this issue when the discussion board is located in the Home area of the portal site or in a Microsoft Windows SharePoint Services Web site.

WORKAROUND

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.
Important The following steps are provided as a general guideline only. Before you perform this workaround, you must contact Microsoft Product Support Services for more information about how to complete the workaround. Microsoft Product Support Services will help you determine and set the value of the FullControlSID registry entry that is required in this workaround.

For a list of Microsoft Product Support Services telephone numbers, visit the following Microsoft Web site: To work around this issue, follow these steps:
  1. Add the FullControlSID registry entry to the following registry subkey:

    HKEY_LOCAL_MACHINE\Software\Microsoft\SharePoint Portal Server

    Then, set the value of the FullControlSID registry entry to the security ID (SID) of the user account that you are logged on as.

    Important Make sure that you contact Microsoft Product Support Services for help to determine the SID that you need and to set the value of the FullControlSID registry entry to the SID.
  2. Run the custom program to add the discussion items to the discussion board.
  3. Delete the FullControlSID registry entry that you added in step 1.

MORE INFORMATION

The following steps describe only how to add the FullControlSID registry entry. Contact Microsoft Product Support Services for help to determine the SID that you need and to set the value of the FullControlSID registry entry to the SID.

To add the FullControlSID registry entry, follow these steps:
  1. Click Start, click Run, type regedit in the Open box, and then click OK.
  2. Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\Software\Microsoft\SharePoint Portal Server

  3. On the Edit menu, point to New, and then click Binary Value.
  4. Type FullControlSID, and then press ENTER.
  5. Double-click FullControlSID. Set the value of the FullControlSID registry entry to the SID of the user account that you are currently logged on as, and then click OK.

    Important Make sure that you contact Microsoft Product Support Services for help to complete this step.
  6. On the File menu, click Exit to exit Registry Editor.

Modification Type:MajorLast Reviewed:5/8/2006
Keywords:kbtshoot kbnofix kbBug kbExpertiseInter kbprb KB915489 kbAudEndUser