A client computer that is connected to a Windows Server 2003-based DHCP server loses network connectivity when the client computer tries to renew its IP address (915458)



The information in this article applies to:

  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Datacenter Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Web Edition

SYMPTOMS

Consider the following scenario:
  • You change an exclusion range on a Microsoft Windows Server 2003-based Dynamic Host Configuration Protocol (DHCP) server. Or, you disable a scope in the Microsoft Management Console (MMC) of the DHCP server.
  • A client computer that is connected to the DHCP server tries to renew its IP address by sending a DHCP request packet to the DHCP server.
In this scenario, the client computer loses network connectivity.

CAUSE

The DHCP server replies to the DHCP request packet by sending a broadcast DHCP negative acknowledgement (NAK) packet instead of by sending a unicast DHCP NAK packet. If the client computer and the DHCP server are located on different IP subnets, the broadcast DHCP NAK packet does not reach the client computer. Therefore, the client computer loses network connectivity.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To install this hotfix, you must have Windows Server 2003 Service Pack 1 (SP1) installed on your computer.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Dhcpssvc.dll5.2.3790.2645733,69622-Feb-200622:40IA-64SP1SP1QFE
Wdhcpssvc.dll5.2.3790.2645270,84822-Feb-200622:40x86SP1WOW
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Dhcpssvc.dll5.2.3790.2645432,64022-Feb-200622:40x64SP1SP1QFE
Wdhcpssvc.dll5.2.3790.2645270,84822-Feb-200622:40x86SP1WOW
Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Dhcpssvc.dll5.2.3790.2645270,84823-Feb-200611:07x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbQFE kbHotfixServer kbWinServ2003preSP2fix kbBug kbfix kbpubtypekc KB915458 kbAudITPRO