When you try to run a custom application or try to open a Web site by using Internet Explorer 6 with SP1, the application or Internet Explorer may stop responding (915355)



The information in this article applies to:

  • Microsoft Internet Explorer 6.0 SP1

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

You try to run a custom application or try to open a Web site by using Microsoft Internet Explorer 6 with Service Pack 1 (SP1). If the application or the Web site uses the Mshtml.dll file and JScript, the application or Internet Explorer may stop responding.

CAUSE

This problem occurs when the Mshtml.dll library holds a loader lock when the application tries to exit. The loader lock may prevent other threads from exiting. This behavior causes a deadlock in the application or in Internet Explorer. Therefore, the application or Internet Explorer may stop responding.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required to install this hotfix.

Restart requirement

You must restart the computer after you apply this hotfix.

Registry information

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

To enable this hotfix, you must add the following registry keys:

FEATURE_JSCRIPT_EXHAUSTIVE_COLLECT_AND_100MS_DOWNLOAD_THREAD_TIMEOUT_KB915355

FEATURE_ENABLE_DXTRANS_SHUTDOWN_TIMEOUT_KB905297

To do this, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE \Software\Microsoft\Internet Explorer\Main\FeatureControl

  3. On the Edit menu, point to New, and then click Key.
  4. Type FEATURE_JSCRIPT_EXHAUSTIVE_COLLECT_AND_100MS_DOWNLOAD_THREAD_TIMEOUT_KB915355, and then press ENTER.
  5. On the Edit menu, click New, and then click DWORD.
  6. Type Iexplore.exe, or type the name of the custom application, and then click OK.
  7. On the Edit menu, click Modify.
  8. Type 1, and then click OK.
  9. Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE \Software\Microsoft\Internet Explorer\Main\FeatureControl

  10. On the Edit menu, point to New, and then click Key.
  11. Type FEATURE_ENABLE_DXTRANS_SHUTDOWN_TIMEOUT_KB905297, and then press ENTER.
  12. On the Edit menu, click New, and then click DWORD.
  13. Type Iexplore.exe, or type the name of the custom application, and then click OK.
  14. On the Edit menu, click Modify.
  15. Type 1, and then click OK.
  16. Exit Registry Editor.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Dxtrans.dll6.3.2800.1535192,51224-Feb-200621:26x86
Iecustom.dll6.0.2800.150236,86419-Apr-200520:56x86
Mshtml.dll6.0.2800.15362,708,99228-Feb-200622:38x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbHotfixServer kbQFE kbpubtypekc KB915355 kbAudITPRO kbAudDeveloper