When you remove an external USB 2.0 hub from a Windows XP-based computer, USB devices that were connected to the USB 2.0 hub are not immediately removed from Device Manager (915326)



The information in this article applies to:

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional

SYMPTOMS

You remove an external USB 2.0 hub from a Microsoft Windows XP-based computer. After you do this, USB devices or optical drives that were connected to the USB 2.0 hub are not immediately removed from Device Manager. The devices remain in Device Manager for several minutes, even though they are no longer connected to the computer.

Note This problem can also occur when you remove a Windows XP-based computer from a docking station. The problem occurs if the docking station contains an integrated USB 2.0 hub that has connected devices.

CAUSE

This problem may occur if an audio-enabled CD device is also connected to the USB 2.0 hub or to the docking station. The problem occurs because the Redbook.sys digital audio playback driver is waiting for a worker thread to exit. The worker thread is waiting for a resource that is held by the Plug and Play manager for the device removal.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Redbook.sys5.1.2600.285857,34428-Feb-200600:10x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:3/23/2006
Keywords:kbQFE kbExpertiseBeginner kbHotfixServer KB915326 kbAudEndUser