You may receive inaccurate reports when you run SMS hardware inventory reports on the parent site server (915198)



The information in this article applies to:

  • Microsoft Systems Management Server 2.0
  • Microsoft Systems Management Server 2003
  • Microsoft Systems Management Server 2003 SP1
  • Microsoft Systems Management Server 2003 SP2

SYMPTOMS

When you view the Microsoft System Management Server (SMS) database hardware inventory reports, you may notice that the hardware information for some client computers is incorrect. For example, the reports may be accurate when you run the hardware inventory reports on a primary child site server. However, the reports may be inaccurate when you run the hardware inventory reports on the parent site server.

This problem may occur when the following conditions are true:
  • You have two or more SMS site servers in the hierarchy.
  • SMS processes multiple inventory data files from the same child site client computer on the parent site in a short time.

CAUSE

This problem occurs when an SMS site server processes the files out of order. This may occur when the SMS site server receives inventory data from a child site.

RESOLUTION

Systems Management Server 2.0

A hotfix is currently unavailable for Systems Management Server 2.0.

Systems Management Server 2003

To resolve this problem, install the hotfix from this article on the SMS site servers.A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Systems Management Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To apply this hotfix, you must have Systems Management Server SP1 installed on the computer.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The Engish version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Basesvr.dll2.50.4160.21081,769,47201-Mar-200608:35x86
Distmgr.dll2.50.4160.2108417,79201-Mar-200608:35x86
Replmgr.dll2.50.4160.210865,53601-Mar-200608:35x86
Sms2003-sp2-kb915198-x86-enu.exe2.50.4160.2108928,56011-May-200614:38x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

After you install this hotfix, the SMS_DESPOOLER component moves files to the SMS_REPLICATION_MANAGER component in chronological order. Additionally, the SMS_REPLICATION_MANAGER component moves files to the other SMS components in chronological order. Formerly, the components moved the files in alphabetical order. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:9/14/2006
Keywords:kbHotfixServer kbSMSInventory kbQFE kbpubtypekc KB915198 kbAudITPRO