Error message when you try to activate Microsoft Office Live Communications Server 2005:"[0xC3EC7821]" (915115)



The information in this article applies to:

  • Microsoft Office Live Communications Server 2005 Enterprise Edition
  • Microsoft Office Live Communications Server 2005 Standard Edition
  • Microsoft Office Live Communications Server 2005 Service Pack 1

SYMPTOMS

When you try to reinstall and then activate Microsoft Office Live Communications Server 2005, activation fails. Additionally, you may receive an error message that is similar to the following:
Failure [0xC3EC7821] Server is associated with one or more invalid SPNs. Use LcsCmd with the /unregspn switch if you would like unregister already registered SPNs.

CAUSE

This problem occurs because an earlier installation uses a different service account. If you do not deactivate the Live Communications Server 2005 server before you install the front-end software, the service principal name (SPN) is still registered on the original service account.

RESOLUTION

To resolve this problem, use one of the following methods:
  • Use the service account where the SPN is already registered.
  • Use LcsCmd.exe with the /unregspn switch to remove the SPN. To do this, type the following command:

    lcscmd.exe /server /action:Activate /role:SE /user:CLService /password:Password /unregspn

  • Locate the service account name that is referenced in the Activation error log, and then clear the ServicePrincipleName value from the account object in Active Directory. To do this, follow these steps:
    1. Run the Adsiedit.msc tool on the domain where Live Communications Server 2005 is installed.
    2. Expand Domain [domain name], expand DC=domain name, DC=com, and then expand CN=Users.

      Note In this step, domain name is a placeholder for the domain where Live Communications Server 2005 is installed.
    3. Right-click service account name, and then click Properties.

      Note In this step, service account name is a placeholder for the name of the service account.
    4. In the Attributes list, double-click ServicePrincipalName.
    5. Remove the fully qualified domain name (FQDN) of Live Communications Server 2005 from this list, and then click OK two times.
    6. Run the Live Communications Server 2005 activation again.

MORE INFORMATION

Use the following command to locate the conflicting SPN in the HTML log file or to validate the SPN that is registered on this service account::

SETSPN -L service account name

Note In this step, account name is a placeholder for the service account name.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:4/10/2006
Keywords:kbtshoot kbprb KB915115 kbAudITPRO