Error message after you reinstall Windows Defender Beta 2: "Windows Defender definitions haven't been updated" (915105)



The information in this article applies to:

  • Windows Defender (Beta 2), when used with:
    • Microsoft Windows Server 2003, Datacenter x64 Edition
    • Microsoft Windows Server 2003, Enterprise x64 Edition
    • Microsoft Windows Server 2003, Standard x64 Edition
    • Microsoft Windows Server 2003, Datacenter Edition for Itanium-based Systems
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
    • Microsoft Windows Server 2003, Datacenter Edition
    • Microsoft Windows Server 2003, Enterprise Edition
    • Microsoft Windows Server 2003, Standard Edition
    • Microsoft Windows Server 2003, Web Edition
    • Microsoft Windows XP Professional x64 Edition
    • Microsoft Windows XP Home Edition
    • Microsoft Windows XP Professional
    • Microsoft Windows 2000 Advanced Server
    • Microsoft Windows 2000 Datacenter Server
    • Microsoft Windows 2000 Professional
    • Microsoft Windows 2000 Server

Beta Information

This article discusses a Beta release of a Microsoft product. The information in this article is provided as-is and is subject to change without notice.

No formal product support is available from Microsoft for this Beta product. For information about how to obtain support for a Beta release, see the documentation that is included with the Beta product files, or check the Web location where you downloaded the release.

SYMPTOMS

After you uninstall and then reinstall Microsoft Windows Defender Beta 2, you may receive the following error message:
Windows Defender definitions haven't been updated
If you check for updated definitions when this occurs, Windows Defender reports that no updates are available.

CAUSE

This problem occurs because after Windows Defender Beta 2 has been reinstalled, it does not automatically obtain new definitions until the next definition update is published on the Windows Update Web site.

RESOLUTION

To resolve this problem, follow these steps:
  1. Remove the current signature file. To do this, click Start, click Run, type Msiexec /x {A5CC2A09-E9D3-49EC-923D-03874BBD4C2C}, and then click OK.
  2. Open Windows Defender. To do this, click Start, click Programs, and then click Windows Defender.
  3. Check for new definitions. To do this, click the Help options arrow next to the Windows Defender Help icon, click About Windows Defender, and then click Check for Updates.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Definitions are files that behave like an encyclopedia of known spyware and other potentially unwanted software. Because spyware is continually being developed, Windows Defender relies on up-to-date definitions to determine whether software that is trying to install, run, or change settings on the computer is potentially harmful.

Windows Defender works with the Windows Automatic Updates feature to automatically install the latest definitions. To make sure that Automatic Updates is on, follow these steps:
  1. Click Start, click Run, type wuaucpl.cpl, and then click OK.
  2. Click Automatic (Recommended), and then click OK.

Technical support for x64-based versions of Microsoft Windows

Your hardware manufacturer provides technical support and assistance for x64-based versions of Windows. Your hardware manufacturer provides support because an x64-based version of Windows was included with your hardware. Your hardware manufacturer might have customized the installation of Windows with unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with your x64-based version of Windows. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about x64-based versions of Microsoft Windows Server 2003, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:2/20/2006
Keywords:kbtshoot kbExpertiseBeginner kberrmsg KB915105 kbAudEndUser