The "DynamicEntity XML" code that you create by using the Opportunity form differs from the "DynamicEntity XML" code that you create by using the "Marketing List" form in Microsoft Dynamics CRM 3.0 (915046)



The information in this article applies to:

  • Microsoft Business Solutions CRM Software Development Kit (SDK), when used with:
    • Microsoft CRM 3.0
  • Microsoft CRM 3.0

The hotfix that is discussed in this article is not available for the Chinese version of Microsoft Dynamics CRM or for the Japanese version of Microsoft Dynamics CRM.

SYMPTOMS

The DynamicEntity XML code that you create by using the Opportunity form differs from the DynamicEntity XML code that you create by using the Marketing List form in Microsoft Dynamics CRM 3.0. This problem occurs even though you use methods that are documented in the Microsoft Dynamics CRM Software Development Kit (SDK) to capture the DynamicEntity XML that is generated when an opportunity is created in Microsoft Dynamics CRM 3.0.

When the opportunity is created by using by using the Create Opportunity functionality on the Opportunity form, the DynamicEntity XML contains text that resembles the following code example.
<Property xsi:type="CustomerProperty" Name="customerid">
     <Value type="account">{A7DAB4C6-E477-DA11-AD18-000874DE7397}</Value>
</Property>
When the opportunity is created by using the Create Opportunity functionality on the Marketing List form, the DynamicEntity XML contains text that resembles the following code example.
<Property xsi:type="LookupProperty" Name="customerid">
     <Value type="account">{A7DAB4C6-E477-DA11-AD18-000874DE7397}</Value>
</Property>

CAUSE

This problem occurs because different property types are used for the customerid attribute when the opportunity is created. The LookupProperty property type can be used for many different entities. The LookupProperty property type produces XML that is passed to the Edit.aspx page of the opportunity. This XML resembles the following code example.
<opportunity>
     <name>Opportunity Name</name>
     <pricelevelid type="1022">{F31BB38A-0EC0-403F-99A6-3AF469D7D76E}</pricelevelid>
     <isrevenuesystemcalculated>1</isrevenuesystemcalculated>
     <opportunityratingcode>2</opportunityratingcode>
     <statuscode>1</statuscode>
     <ownerid type="8">{E23750FB-AD71-DA11-AAAA-000D56C2E08A}</ownerid>
     <accountid>{A7DAB4C6-E477-DA11-AD18-000874DE7397}</accountid>
</opportunity>
The CustomerProperty property type is only used for accounts, for contacts, and for leads. The CustomerProperty property type produces XML that is passed to the Edit.aspx page of the opportunity. The XML resembles the following code example:
<opportunity>
     <name>Opportunity Name</name>
     <customerid type="1">{A7DAB4C6-E477-DA11-AD18-000874DE7397}</customerid>
     <pricelevelid type="1022">{F31BB38A-0EC0-403F-99A6-3AF469D7D76E}</pricelevelid>
     <isrevenuesystemcalculated>1</isrevenuesystemcalculated>
     <opportunityratingcode>2</opportunityratingcode>
     <ownerid type="8">{E23750FB-AD71-DA11-AAAA-000D56C2E08A}</ownerid>
     <statuscode>1</statuscode>
</opportunity>

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Dynamics CRM 3.0 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Installation information

Install this update on computers that are running the server component of Microsoft Dynamics CRM 3.0.

Prerequisites

There are no prerequisites for this hotfix.

Removal information

To remove this hotfix, use the Add or Remove Programs item in Control Panel.

Restart requirement

If you are prompted, restart the computer after you install the hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTime
Appgrid.htcNot Applicable11,81520-Mar-200623:44
Microsoft.crm.application.components.application.dll3.0.5300.1085686,85620-Mar-200623:56
Microsoft.crm.application.pages.dll3.0.5300.1085965,38420-Mar-200623:56
Print_dlg.aspxNot Applicable8,81620-Mar-200623:44
Systemsettings.aspxNot Applicable33,17120-Mar-200623:44

MORE INFORMATION

For more information about the terminology that is used to describe Microsoft software updates, click the following article numbers to view the articles in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

887283 Microsoft Business Solutions CRM software hotfix and update package naming standards


Modification Type:MinorLast Reviewed:9/13/2006
Keywords:kbHotfixServer kbBug kbQFE kbMBSMigrate kbpubtypekc KB915046 kbAudEndUser kbAudDeveloper