Installation of the Windows SBS 2003 Transition Pack may silently fail on a Windows SBS 2003-based computer (914990)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Small Business Server 2003, Standard Edition
  • Microsoft Small Business Server 2000
  • Microsoft Windows Small Business Server 2003, Premium Edition

SYMPTOMS

Consider the following scenario:
  • You install the Microsoft Windows Small Business Server (Windows SBS) 2003 Transition Pack on a Windows SBS 2003-based computer.
  • The Backup Exec program is installed on this computer.
  • The Windows SBS 2003 Transition Pack indicates that it has installed successfully.
In this scenario, the installation may silently fail. The computer is now neither a Windows SBS 2003-based computer nor a Microsoft Windows Server 2003-based computer.

Additionally, you may experience one or more of the following symptoms:
  • The computer displays a Windows Server 2003 startup screen, but the Microsoft Windows XP logo appears in the Start menu. The Windows XP logo may also appear when a service starts or when you run the Winver tool.
  • The Windows SBS 2003 Transition Pack stops and then displays an error message that states that you are running Microsoft Small Business Server 4.0 or Microsoft Small Business Server 4.5.
  • If you try to install Windows Server 2003 Service Pack 1 on the computer, a Windows Activation window appears when the computer restarts. However, Windows does not start.
  • Windows SBS 2003-specific functionality, such as licensing, is still referenced. However, the functionality does not work because of missing DLL paths.
  • The Terminal Services service is unavailable in Add or Remove Programs.
  • The product ID (PID) is still a Windows SBS 2003 PID.

    Note To view the PID, right-click My Computer, and then click Properties. The PID appears in the Registered section on the General tab. Typically, a Windows SBS 2003 PID starts with 74995.

CAUSE

This issue occurs because the Windows SBS 2003 Transition Pack does not finish installing. When you install the Windows SBS 2003 Transition Pack, the software verifies the version of Windows SBS 2003 that is installed. In this scenario, the Transition Pack determines that the version of Windows SBS 2003 is earlier than what the Transition Pack supports. Therefore, the Transition Pack cannot complete the conversion process.

The Transition Pack uses the following registry subkey to determine the Windows SBS 2003 version:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Small Business\Console\CustomSMTasks\Link1

Notes
  • This registry subkey is no longer used by Microsoft Small Business Server 2000 or by Windows SBS 2003.
  • When you install version 9.x or version 10.x of the Backup Exec program on a computer that is running Small Business Server 2000 or Windows SBS 2003, the Backup Exec program adds this registry subkey.

RESOLUTION

To resolve this problem immediately, contact Microsoft Product Support Services for more information. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, visit the following Microsoft Web sites: The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbQFE kbfix kbExchange2000preSP4fix kbbug kbtshoot kbprb kbpubtypekc KB914990 kbAudITPRO