Microsoft Operations Manager 2005 may stop processing incoming SNMP traps after receiving many traps in a short time (914835)



The information in this article applies to:

  • Microsoft Operations Manager 2005
  • Microsoft Operations Manager 2005 SP1

SYMPTOMS

Under certain conditions, Microsoft Operations Manager (MOM) 2005 may stop processing incoming Simple Network Management Protocol (SNMP) traps. This generally occurs after MOM 2005 receives many SNMP traps in a short time. By restarting the MOM service (MOMService.exe), you can bring SNMP trap processing back online for a short time. However, the problem will probably occur again.

CAUSE

This problem occurs because MOM 2005 does not correctly handle a specific error condition that Windows Management Instrumentation (WMI) returns. This hotfix makes sure that MOM 2005 re-subscribes to the SNMP trap events with WMI after error conditions such as this occur.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Operations Manager 2005 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

The hotfix requires Microsoft Operations Manager 2005 Service Pack 1.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other software updates.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

x86

File nameFile versionFile sizeDateTime
momactions.dll5.0.2911.32900,84802-Mar-200600:32

ia64

File nameFile versionFile sizeDateTime
Momactions.dll5.0.2911.323,191,53610-Mar-200618:22

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

There is nothing logged in the MOM or WBEMSNMP logs that indicates the problem has occurred. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:5/11/2006
Keywords:kbHotfixServer kbfix kbQFE kbExpertiseInter kbOpman2005spfix KB914835 kbAudITPRO