You may receive an error message about the Prefs.js file or about saving preferences when you use Netscape or Mozilla with Groove Workspace (914743)



The information in this article applies to:

  • Groove Workspace 2.5 Preview Edition
  • Groove Workspace 2.5 Professional Edition
  • Groove Workspace 2.5 Project Edition
  • Groove Workspace 2.5 Standard Edition

SYMPTOMS

You may receive an error message about the Prefs.js file when you use Groove Workspace. Alternatively, you may receive the following error message when you exit Netscape or Mozilla while Groove Workspace is still active:
Failed to save the preferences file. Any preference change will be lost at the end of this session.

CAUSE

In Groove Workspace 2.5i and in earlier versions of Groove Workspace, the Groove ProxyConfigRamp sometimes must open the Netscape Prefs.js file when Groove processes a Netscape event. If Netscape has this file open, the attempt fails. Additionally, Groove returns an error message. If Groove opens the file successfully but has the file open when Netscape tries to save changed preferences when Netscape exits, the save operation fails. Additionally, Netscape returns an error message.

MORE INFORMATION

In Groove Workspace 2.5j and in later versions of Groove Workspace, Groove no longer tries to access the Netscape Prefs.js file. Therefore, the proxy information must be correctly configured in Microsoft Internet Explorer, even if you use Netscape as your primary browser. The correctly configured proxy information in Internet Explorer prevents this issue and other interoperability problems that may occur between Groove Workspace and Netscape or Mozilla.

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:4/3/2006
Keywords:kbprb kbExpertiseInter kbtshoot KB914743 kbAudKnowledgeWorker