Error message when you try to view the activities for an account in Microsoft Dynamics CRM 3.0: "A SQL Server error occurred" (914644)



The information in this article applies to:

  • Microsoft CRM 3.0

The hotfix that is discussed in this article is not available for the Chinese version of Microsoft Dynamics CRM or for the Japanese version of Microsoft Dynamics CRM.

SYMPTOMS

You cannot view the activities for an account in Microsoft Dynamics CRM 3.0. Additionally, you receive the following error message:
SQL Server Error

A SQL Server error occurred. For more information, contact your system administrator.
If you have the DevErrors parameter enabled, you also receive the following error message:
Microsoft CRM Unhandled Error Details:
Server Error in '/' Application.
--------------------------------------------------------------------------------

Server was unable to process request.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Web.Services.Protocols.SoapException: Server was unable to process request.

Source Error: An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:

[SoapException: Server was unable to process request.]
System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message,
WebResponse response, Stream responseStream, Boolean asyncCall) +1495
System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters) +217
Microsoft.Crm.Platform.Proxy.ActivityPointerWebService.RollupByObject(Guid rollupById, String rollupByName, RollupType rollupType, QueryBase queryExpression) +148
Microsoft.Crm.Application.SMWrappers.ActivityPointer.RollupByObject(Guid rollupById, String rollupByName, RollupType rollupType, QueryExpression activityQueryExpression) +44
Microsoft.Crm.Application.Platform.ActivityPointer.RollupByObject(CObjectName gridObjectName, RollupType rollupType, QueryExpression activityQueryExpression) +119
Microsoft.Crm.ApplicationQuery.ExecuteActivityAPI(String api) +232
Microsoft.Crm.ApplicationQuery.ExecuteAPI(String queryApi) +2726
Microsoft.Crm.ApplicationQuery.GetViewData() +91 Microsoft.Crm.Application.Controls.ActivitiesGridDataProvider.GetDataXml(QueryBuilder qb) +189 Microsoft.Crm.Application.Controls.AppGridDataProvider.Execute() +156 Microsoft.Crm.Application.Controls.ActivitiesGridDataProvider.Execute() +4 Microsoft.Crm.Application.Controls.AppGridUIProvider.Render(HtmlTextWriter output) +229 Microsoft.Crm.Application.Components.UI.DataGrid.RenderData(HtmlTextWriter output) +525 Microsoft.Crm.Application.Components.UI.DataGrid.RenderInnerHtml(HtmlTextWriter output) +471 Microsoft.Crm.Application.Components.UI.DataGrid.Render(HtmlTextWriter output) +125 Microsoft.Crm.Application.Controls.AppGrid.Render(HtmlTextWriter writer) +128 System.Web.UI.Control.RenderControl(HtmlTextWriter writer) +243 Microsoft.Crm.Application.Controls.AppAreaPage.Render(HtmlTextWriter output) +427 System.Web.UI.Control.RenderControl(HtmlTextWriter writer) +243
System.Web.UI.Page.ProcessRequestMain() +1926

CAUSE

This problem may occur if the following conditions are true:
  • A lead is converted to an opportunity. Additionally, the lead is associated with an existing account.
  • The lead is re-activated.
  • The lead is again converted to an opportunity. Additionally, the lead is associated with the same existing account with which it was associated before.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Business Solutions CRM 3.0 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Installation information

Install this hotfix on computers that are running Microsoft CRM 3.0 Client or Microsoft CRM 3.0 Server.

Prerequisites

There are no prerequisites to install this hotfix.

Removal information

To remove this hotfix from a computer that is running Microsoft Dynamics CRM 3.0, use Add or Remove Programs in Control Panel. System administrators can use the Spunist.exe utility to remove this hotfix from a computer that is running Microsoft Dynamics CRM 3.0. The Spuninst.exe tool is located in the %Windir%\$NTUninstallKB919354$\Spuninst folder.

Restart requirement

If you are prompted, restart the computer after you install the hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile sizeDateTime
Invoice status detail.rdl63,43626-Apr-200607:37
Invoice status.rdl31,78826-Apr-200607:37
Sales pipeline.rdl108,50726-Apr-200607:37
Service activity volume detail.rdl100,12426-Apr-200607:37
Service activity volume.rdl65,20016-May-200606:56

MORE INFORMATION

For more information about the terminology that is used to describe Microsoft software updates, click the following article numbers to view the articles in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

887283 Microsoft Business Solutions CRM software hotfix and update package naming standards


Modification Type:MajorLast Reviewed:7/5/2006
Keywords:kberrmsg kbBug kbMBSMigrate kbmsccsearch kbpubtypekc KB914644 kbAudEndUser kbAudDeveloper