Workflow rules are paused after you upgrade to Microsoft Dynamics CRM 3.0 (914594)



The information in this article applies to:

  • Microsoft CRM 3.0

SYMPTOMS

After you upgrade to Microsoft Dynamics CRM 3.0, the following workflow rules are paused:
  • Workflow rules that were upgraded from Microsoft CRM 1.2
  • New workflow rules

CAUSE

This issue occurs because the System Administrator account was the only user account that could create workflow rules in earlier versions of Microsoft CRM. By default, the Restricted Access Mode check box is selected when you upgrade to Microsoft Dynamics CRM 3.0. Therefore, you can no longer run workflow rules after the upgrade.

RESOLUTION

To resolve this issue, use one of the following methods.

Method 1: Clear the "Restricted Access mode" check box

  1. Log on to the Microsoft CRM Web client by using the System Administrator account.
  2. Click Settings, click Settings, click Business Unit Settings, and then click Users.
  3. Double-click the System Administrator account.
  4. Click to clear the Restricted Access Mode check box.
  5. Click Save and Close.
Note This method uses a license for the System Administrator account.

Method 2: Give another user the appropriate permissions, and then resave the rules that were created by the System Administrator account

  1. Log on to the Microsoft CRM Web client by using the System Administrator account.
  2. Click Settings, click Settings, click Business Unit Settings, and then click Users.
  3. Double-click the user to whom you want to assign the workflow rights.
  4. Click Roles.
  5. Click Manage Roles.
  6. Click to select the System Customizer check box, and then click OK.
  7. Click Save and Close.
  8. Log on to the Microsoft CRM server as the user who you selected in step 3.
  9. Click Start, point to Programs, click Microsoft CRM, and then click Workflow Manager.
  10. In the Workflow Manager Log On dialog box, type the name of a Microsoft CRM server in the Target Microsoft CRM server box, and then click OK.
  11. Select a rule, and then click Deactivate on the toolbar.
  12. Double-click the rule to open it.
  13. Click Save.
  14. Click Activate on the toolbar.
  15. Repeat steps 11 through 14 for each rule that was created by the System Administrator account.

MORE INFORMATION

Steps to reproduce this problem

  1. Click Settings, click Settings, click Business Unit Settings, and then click Users.
  2. Double-click the System Administrator account.
  3. Click to select the Restricted Access Mode check box.
  4. Click Save and Close.
  5. Create a workflow rule.
  6. Perform the action to trigger that rule.

Modification Type:MinorLast Reviewed:3/7/2006
Keywords:kbMBSupgrade kbMBSworkflow kbtshoot kbMBSMigrate kbprb KB914594 kbAudEndUser kbAudKnowledgeWorker