Event ID: 1080 occurs every three seconds when you are using Exchange Server 2003 SP2 in a clustered environment (914148)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Service Pack 2, when used with:
    • Microsoft Exchange Server 2003 Enterprise Edition

SYMPTOMS

Consider the following scenario:
  • You are using Microsoft Exchange Server 2003 Service Pack 2 (SP2) in a clustered environment.
  • In Exchange System Manager, you manually add a domain controller for the Configuration domain controller on the Directory Access tab of the ServerName Properties dialog box.
  • After you close this dialog box, you later reopen it. You click to select the Automatically discover servers check box on the Directory Access tab. Then, you close the ServerName Properties dialog box.
In this scenario, you experience all the following symptoms:
  • The following event is logged in the System log every three seconds. This event is logged even though the Exchange services are operating as expected.Event Type: Error
    Event Source: ClusSvc
    Event Category: Database Mgr
    Event ID: 1080
    Date: date
    Time: time
    User: N/A
    Computer: ComputerName
    Description: Cluster service could not write to a file (C:\DOCUME~1\ADMINI~1.DIE\LOCALS~1\Temp\CLS77.tmp). The disk may be low on disk space, or some other serious condition exists.

    Data: 0000: fa 03 00 00 ú.
  • The following entries are logged in the Cluster.log file every three seconds:

    000006a8.00000fa0::2005/04/27-09:54:13.085 INFO [CP] CppRegNotifyThread checkpointing key System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0 to id 3 due to timer
    000006a8.00000fa0::2005/04/27-09:54:13.085 INFO [Qfs] QfsGetTempFileName C:\DOCUME~1\ADMINI~1.DIE\LOCALS~1\Temp\, CLS, 119 => C:\DOCUME~1\ADMINI~1.DIE\LOCALS~1\Temp\CLS77.tmp, status 0 
    000006a8.00000fa0::2005/04/27-09:54:13.085 INFO [Qfs] QfsDeleteFile C:\DOCUME~1\ADMINI~1.DIE\LOCALS~1\Temp\CLS77.tmp, status 0 000006a8.00000fa0::2005/04/27-09:54:13.085 INFO [Qfs] QfsRegSaveKey C:\DOCUME~1\ADMINI~1.DIE\LOCALS~1\Temp\CLS77.tmp, status 1018 
    000006a8.00000fa0::2005/04/27-09:54:13.085 INFO [Qfs] QfsDeleteFile C:\DOCUME~1\ADMINI~1.DIE\LOCALS~1\Temp\CLS77.tmp, status 0 
    000006a8.00000fa0::2005/04/27-09:54:13.085 WARN [CP] CppCheckpoint failed to get registry database System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0 to file C:\DOCUME~1\ADMINI~1.DIE\LOCALS~1\Temp\CLS77.tmp error 1018 
    000006a8.00000fa0::2005/04/27-09:54:13.085 INFO [Qfs] QfsDeleteFile C:\DOCUME~1\ADMINI~1.DIE\LOCALS~1\Temp\CLS77.tmp, status 2 
    000006a8.00000fa0::2005/04/27-09:54:13.085 WARN [CP] CppRegNotifyThread CppNotifyCheckpoint due to timer failed, reset the timer. 

  • The Automatically discover servers check box on the Directory Access tab of the ServerName Properties dialog box is no longer selected. Instead, the domain controller entry that you previously specified for the Configuration domain controller appears on this tab.

CAUSE

This problem occurs because the Instance0 registry subkey is removed from the following subkey in the scenario that is described in the "Symptoms" section:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeDSAccess\Instance0

The Instance0 subkey is removed only if no subkeys exist under the Instance0 subkey. By default, no subkeys exist under the Instance0 subkey. The Instance0 subkey is included in registry synchronization in Exchange Server 2003 SP2 clustering. Therefore, the event that is described in the "Symptoms" section is logged when this subkey is missing.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Exchange Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Exmgmt.exe6.5.7651.73,217,40825-Feb-200603:33x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

817903 New naming schema for Exchange Server software update packages


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbQFE kbfix kbBug kbpubtypekc KB914148 kbAudITPRO