A program can no longer access the registry on a remote computer after you install Windows Server 2003 Service Pack 1 (914057)



The information in this article applies to:

  • Microsoft Windows Server 2003 SP1, when used with:
    • Microsoft Windows Server 2003, Standard Edition
    • Microsoft Windows Server 2003, Enterprise Edition
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard x64 Edition

SYMPTOMS

A program is no longer able to access the registry on a remote computer from a Microsoft Windows Server 2003-based computer after you install Windows Server 2003 Service Pack 1 (SP1). This symptom only occurs if you are not logged on to the computer by using the administrator account or other account that has elevated security rights.

CAUSE

This behavior occurs because security changes in Windows Server 2003 SP1 require that credentials with elevated security rights, such as administrator credentials, be used to access the registry on a remote computer.

When a program tries to access the registry on a remote computer, Windows Server 2003 calls the RegConnectRegistry function. The RegConnectRegistry function uses cached credentials for authentication. If the current user does not have appropriate access to the remote computer, the call to RegConnectRegistry fails.

For more information about the RegConnectRegistry function, visit the following Microsoft MSDN Web site:

WORKAROUND

To work around this behavior, use either of the following methods.

Method 1

Use the Run as command on the remote computer to start the program as an administrator. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

325362 How to use "Run as" to start an application as an administrator in Windows Server 2003

Method 2

Use the Windows Credential Manager feature to cache the appropriate credentials on the local computer and to automatically associate those credentials with the remote computer. To do this, follow these steps:
  1. Log on to the remote computer by using the appropriate credentials, such as administrator credentials.
  2. In the dialog box where you are prompted for these credentials, click to select the Update Default Credentials option or the Save Password option, and then click OK.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:

913485 Cached credentials security in Windows Server 2003, in Windows XP, and in Windows 2000

STATUS

This behavior is by design.

MORE INFORMATION

Technical support for x64-based versions of Microsoft Windows

Your hardware manufacturer provides technical support and assistance for x64-based versions of Windows. Your hardware manufacturer provides support because an x64-based version of Windows was included with your hardware. Your hardware manufacturer might have customized the installation of Windows with unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with your x64-based version of Windows. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about x64-based versions of Microsoft Windows Server 2003, visit the following Microsoft Web site:

Modification Type:MajorLast Reviewed:3/13/2006
Keywords:kbtshoot kbprb KB914057 kbAudITPRO