FIX: A 0x6be exception may occur when you quickly make multiple remote procedure calls to a server that is running Windows Server 2003 (913957)



The information in this article applies to:

  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter Edition
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Standard x64 Edition

SYMPTOMS

Consider the following scenario. You quickly make multiple remote procedure calls (RPCs) to a server that is running Microsoft Windows Server 2003. The multiple RPCs are on the same endpoint. In this scenario, a 0x6be exception may occur.

CAUSE

This problem occurs because an RPC can reuse a TCP connection that the server has already asked to close. When the RPC does this, the server responds by using an ACK/RST packet. Additionally, the server causes the 0x6be exception to occur on the client computer.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

There are no prerequisites for this hotfix.

Restart information

You do not have to restart the computer after you apply this hotfix.

Registry information

You do not have to change the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.Windows Server 2003 32-bit versions
File nameFile versionFile sizeDateTimePlatform
Rpcrt4.dll5.2.3790.2684645,63218-Apr-200603:19x86
W03a2409.dll5.2.3790.268424,57618-Apr-200601:38x86
Windows Server 2003 64-bit version
File nameFile versionFile sizeDateTimePlatform
Rpcrt4.dll5.2.3790.26841,720,83218-Apr-200603:12x64
W03a2409.dll5.2.3790.268425,08818-Apr-200603:12x64
Windows Server 2003 Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Rpcrt4.dll5.2.3790.26842,470,91218-Apr-200603:12IA-64
W03a2409.dll5.2.3790.268423,55218-Apr-200603:12IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbWinServ2003preSP2fix kbfix kbBug kbHotfixServer kbQFE kbpubtypekc KB913957 kbAudDeveloper kbAudITPRO