The Inetinfo.exe process uses lots of memory when you have a large queue of e-mail messages that are addressed to many different domains on a Windows Server 2003-based computer (913893)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003 Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Web Edition

SYMPTOMS

When you have a large queue of e-mail messages that are addressed to many different domains on a Microsoft Windows Server 2003-based computer that uses Simple Mail Transfer Protocol (SMTP), the Inetinfo.exe process uses lots of memory.

CAUSE

This problem occurs because the Windows Server 2003 advanced queuing engine has lock tracking enabled for many message queue objects.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 (SP1) installed on the computer.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.Windows Server 2003, 64-bit x64-based versions
File nameFile versionFile sizeDateTimePlatform
Aqueue.dll6.0.3790.2669773,63228-Mar-200605:25x64
Windows Server 2003, 64-bit Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Aqueue.dll6.0.3790.26691,485,31228-Mar-200605:25IA-64
Windows Server 2003, 32-bit x86-based versions
File nameFile versionFile sizeDateTimePlatform
Aqueue.dll6.0.3790.2669501,76028-Mar-200605:55x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbWinServ2003preSP2fix kbBug kbfix kbQFE kbhotfixserver kbpubtypekc KB913893 kbAudITPRO