An ActiveX control may not be displayed correctly when you scroll horizontally in the ActiveX control in Internet Explorer 6 (913830)



The information in this article applies to:

  • Microsoft Internet Explorer 6.0, when used with:
    • Microsoft Windows XP Service Pack 2, when used with:
      • Microsoft Windows XP Professional
      • Microsoft Windows XP Home Edition
    • Microsoft Windows XP Service Pack 1, when used with:
      • Microsoft Windows XP Professional
      • Microsoft Windows XP Home Edition

SYMPTOMS

When you scroll horizontally in an ActiveX control in Microsoft Internet Explorer 6, the ActiveX control may not be displayed correctly. This problem only occurs when the ActiveX control uses the WS_EX_LAYOUTRTL style for right-to-left rendering. When this problem occurs, the width of the ActiveX control does not fully display.

CAUSE

This problem occurs because the Graphics Device Interface (GDI) does not convert the coordinates of the ActiveX control into the coordinate system of the computer. The ActiveX control uses a right-to-left (RTL) coordinate system. The computer uses a left-to-right (LTR) coordinate system. When the GDI does not convert the coordinates of the ActiveX control into the coordinate system of the computer, the ActiveX control may not be displayed correctly.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To apply this hotfix, you must have Microsoft Windows XP Service Pack 1 (SP1) or Windows XP Service Pack 2 (SP2) installed on the computer.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Mshtml.dll6.0.2800.15322,706,94426-Jan-200611:53x86SP1
Browseui.dll6.0.2900.28381,022,97601-Feb-200606:28x86SP2SP2QFE
Iepeers.dll6.0.2900.2838251,90401-Feb-200606:28x86SP2SP2QFE
Mshtml.dll6.0.2900.28383,073,02401-Feb-200606:29x86SP2SP2QFE
Shdocvw.dll6.0.2900.28381,495,04001-Feb-200606:29x86SP2SP2QFE
Shlwapi.dll6.0.2900.2838474,11201-Feb-200606:29x86SP2SP2QFE
Urlmon.dll6.0.2900.2838613,37601-Feb-200606:29x86SP2SP2QFE
Xpsp3res.dll5.1.2600.283822,52801-Feb-200601:02x86SP2SP2QFE

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbQFE kbHotfixServer kbWinXPsp2fix kbWinXPsp1fix kbBug kbfix kbpubtypekc KB913830 kbAudEndUser kbAudITPRO