FIX: Windows Media Digital Rights Manager protected files may not correctly play back on Windows XP Media Center Edition 2005-based computers that have Update Rollup 2 installed (913800)



The information in this article applies to:

  • Microsoft Windows XP Media Center Edition 2005 Update Rollup 2

SYMPTOMS

Microsoft Windows Media Digital Rights Manager (WMDRM) protected files may not correctly play back on Microsoft Windows XP Media Center Edition 2005-based computers that have Update Rollup 2 installed. When you try to play back these files, you may receive one of the following error messages:

Error message 1

Restricted Content: Restrictions set by the broadcaster and/or originator of the content prohibit playback of the program on this computer

Error message 2

0xC00D2751: A problem has occurred in the Digital Rights Management component. Contact Microsoft product support

Error message 3

0xC00D2783: The Digital Rights Management data storage is not functioning properly. Contact Microsoft product support.

Error message 4

0xC00D277F: Secure storage protection error. Restore your licenses from a previous backup and try again.

CAUSE

This problem may occur when one or more of the following conditions are true:
  • You roll the computer back to an earlier System Restore point.
  • You uninstall Update Rollup 2 for Windows XP Media Center Edition 2005.
  • After you install Update Rollup 2 for Windows XP Media Center Edition 2005, you install an application, such as Microsoft Windows Media Player 10.
  • You install an application that redistributes the core Windows Media runtime files.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update rollup that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The following file is available for download from the Microsoft Download Center:
DownloadDownload the WindowsMedia10-KB913800-x86-ENU.exe package now.

For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to obtain Microsoft support files from online services

Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTime
Blackbox.dll11.0.0.4346429,05603-Mar-200612:26
Cewmdm.dll10.0.3790.4332207,87204-Aug-200501:14
Drmupgds.exe11.0.0.4332178,93604-Aug-200501:24
Drmv2clt.dll11.0.0.4346581,63203-Mar-200612:26
Kb913800.exe11.0.0.435023,04021-Mar-200603:23
Laprxy.dll10.0.0.43326,65604-Aug-200501:14
Logagent.exe10.0.0.433296,76804-Aug-200500:59
Mfplat.dll11.0.0.4332106,49604-Aug-200500:57
Msnetobj.dll11.0.0.4332115,20004-Aug-200500:57
Mspmsnsv.dll10.0.3790.433225,08804-Aug-200501:14
Mspmsp.dll10.0.3790.4332173,56804-Aug-200501:14
Msscp.dll11.0.0.4332353,52004-Aug-200501:24
Mswmdm.dll10.0.3790.4332315,90403-Aug-200521:14
Qasf.dll10.0.0.4332221,18404-Aug-200501:14
Uwdf.exe5.2.3790.123047,10404-Aug-200501:05
Wdfapi.dll5.2.3790.123015,87204-Aug-200501:05
Wdfmgr.exe5.2.3790.123038,91204-Aug-200501:05
Wmadmod.dll10.0.0.4332359,93604-Aug-200501:14
Wmadmoe.dll10.0.0.4332716,28804-Aug-200501:14
Wmasf.dll10.0.0.4332227,84004-Aug-200501:14
Wmdmlog.dll10.0.3790.433229,18404-Aug-200501:14
Wmdmps.dll10.0.3790.433237,37604-Aug-200501:14
Wmdrmdev.dll10.0.0.4332344,06404-Aug-200501:14
Wmdrmnet.dll10.0.0.4332290,81604-Aug-200501:14
Wmdrmsdk.dll11.0.0.4332180,22404-Aug-200500:57
Wmidx.dll10.0.0.4332150,01604-Aug-200501:14
Wmnetmgr.dll10.0.0.4332988,67204-Aug-200501:14
Wmp.dll10.0.0.39375,533,69602-Jul-200515:03
Wmplayer.exe10.0.0.393173,72824-Jun-200501:09
Wmploc.dll10.0.0.39313,371,00824-Jun-200501:15
Wmsdmod.dll10.0.0.4332771,58404-Aug-200501:14
Wmsdmoe2.dll10.0.0.43321,119,74403-Aug-200521:14
Wmsetsdk.exe10.0.0.4332819,20004-Aug-200501:05
Wmspdmod.dll10.0.0.4332407,55204-Aug-200501:14
Wmspdmoe.dll10.0.0.4332940,54403-Aug-200521:14
Wmvadvd.dll10.0.0.43321,216,00004-Aug-200501:14
Wmvadve.dll10.0.0.43321,512,44804-Aug-200501:14
Wmvcore.dll10.0.0.43322,330,62404-Aug-200501:14
Wmvdmod.dll10.0.0.4332826,36804-Aug-200501:14
Wmvdmoe2.dll10.0.0.43321,003,00804-Aug-200501:14
Wpdconns.dll5.2.3811.434661,95203-Mar-200612:32
Wpdmtp.dll5.2.3811.4346114,17603-Mar-200612:33
Wpdmtpdr.dll5.2.3811.4346331,77603-Mar-200612:33
Wpdmtpus.dll5.2.3811.434666,56003-Mar-200612:33
Wpdsp.dll5.2.3811.4346329,72803-Mar-200612:33
Wpdtrace.dll5.2.3811.434610,75203-Mar-200612:32
Wpdusb.sys5.2.3811.434618,94403-Mar-200612:33
Wpd_ci.dll5.2.3811.434638,91203-Mar-200612:33

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

If you still experience this problem after you apply this software update, you must re-individualize Windows Media Player. To do this, follow these steps:
  1. Close the Media Center interface, and then turn off any connected Media Center extenders.
  2. Upgrade your security components. To do this, visit the following Microsoft Web page, and then click Upgrade:
  3. Restart the computer.

Modification Type:MajorLast Reviewed:4/14/2006
Keywords:kbfix KB913800 kbAudDeveloper kbAudEndUser kbAudOEM