Outlook 2003 unexpectedly quits after an item is created by programmatically using the CreateItemFromTemplate method (913707)



The information in this article applies to:

  • Microsoft Office Outlook 2003

SYMPTOMS

After an item such as a form is created from a template (.oft) by programmatically using the CreateItemFromTemplate method in Microsoft Office Outlook 2003, Outlook unexpectedly quits (crashes). Additionally, you receive the following error message:
Microsoft Office Outlook has encountered a problem and needs to close. We are sorry for the inconvenience.
When you view the data in the error report, the report contains an error signature that is similar to the following error signature.
Application nameApplication versionModule nameModule versionOffset
Outlook.exe11.0.8005.0Outllib.dll11.0.8008.00002921a
Additionally, other program versions, module versions, and offsets are possible.

CAUSE

This problem occurs after the Outlook 2003 post-Service Pack 2 hotfix package that is dated November 16, 2005 is applied.

For more information about the Outlook 2003 post-Service Pack 2 hotfix package that is dated November 16, 2005, click the following article number to view the article in the Microsoft Knowledge Base:

910283 Description of the Outlook 2003 post-Service Pack 2 hotfix package: November 16, 2005

RESOLUTION

How to obtain the hotfix

This issue is fixed in the Outlook 2003 post-Service Pack 2 Hotfix Package that is dated January 23, 2006. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

913695 Description of the Outlook 2003 post-Service Pack 2 hotfix package: January 23, 2006

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbAutomation kbExpertiseInter kbQFE kbbug kbfix kbpubtypekc KB913707 kbAudITPRO