FIX: The attachment is stored as an unmanaged link when the file name contains a letter that has a grave accent in MCMS 2002 Service Pack 2 and in MCMS 2002 Service Pack 1a (913706)



The information in this article applies to:

  • Microsoft Content Management Server 2002 SP2
  • Microsoft Content Management Server 2002 SP1a

SYMPTOMS

Consider the following scenario. In Microsoft Content Management Server (MCMS) 2002 Service Pack 2 (SP2) and in Microsoft Content Management Server 2002 Service Pack 1a (SP1a), you upload a file as a local attachment. The file name contains a character that is not a standard ASCII character. For example, the file name contains a letter that has a grave accent. In this scenario, the attachment is stored as an unmanaged link. After the background processing runs and after the node cache and the disk cache are purged, the linked resources are removed from the database. After this process is completed, the link in the placeholder is listed as a broken link.

CAUSE

This problem occurs because HTML encoding causes the newly uploaded file not to be recognized when the Web page is saved.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next MCMS 2002 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

File information

The global version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTime
Microsoft.contentmanagement.webauthor.dll5.0.5101.0397,31210-Jan-200602:47

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:7/17/2006
Keywords:kbQFE kbbug kbfix kbContentMgtServ2002SP2Fix kbhotfixserver kbmsccsearch kbpubtypekc KB913706 kbAudDeveloper kbAudITPRO