The "Parent Account" and "Parent Customer" fields are unavailable when you try to bulk edit many Contact records or many Account records in Microsoft Dynamics CRM 3.0 (913645)



The information in this article applies to:

  • Microsoft CRM 3.0

The hotfix that is discussed in this article is not available for the Chinese version of Microsoft Dynamics CRM or for the Japanese version of Microsoft Dynamics CRM.

SYMPTOMS

You try to bulk edit many Contact records or many Account records in Microsoft Dynamics CRM 3.0 by using the Advanced Find feature. However, the Parent Account and Parent Customer fields are unavailable. Therefore, you cannot associate the Account or Contact records with a parent account.

CAUSE

This problem occurs because the Parent Account and Parent Customer fields are unavailable when you select many Contact records or many Account records by using the Advanced Find feature.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Dynamics CRM 3.0 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site: Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Microsoft Dynamics CRM 3.0 Client

File nameFile versionFile sizeDateTimePlatform
Appgrid.htcNot Applicable11,817July 16, 200604:08Not Applicable
Microsoft.crm.application.components.application.dll3.0.5300.1232596,856July 18, 200608:41x86
Microsoft.crm.application.components.sdk.formcontrols.dll3.0.5300.123288,968July 18, 200608:40x86
Microsoft.crm.application.components.strings.dll3.0.5300.1232719,728July 18, 200608:46x86
Microsoft.crm.application.components.ui.dll3.0.5300.1232220,008July 18, 200608:45x86
Microsoft.crm.application.pages.dll3.0.5300.1232736,088July 18, 200608:43x86
Print_dlg.aspxNot Applicable8,816July 16, 200604:08Not Applicable

Microsoft Dynamics CRM 3.0 Server

File nameFile versionFile sizeDateTimePlatform
Appgrid.htcNot Applicable11,817July 16, 200604:07Not Applicable
Customizations.xsdNot Applicable53,786July 16, 200604:07Not Applicable
Manageattribute.aspxNot Applicable12,756July 16, 200604:06Not Applicable
Manageattribute.jsNot Applicable15,568July 16, 200604:06Not Applicable
Microsoft.crm.application.components.application.dll3.0.5300.1232686,968July 18, 200608:42x86
Microsoft.crm.application.components.sdk.formcontrols.dll3.0.5300.123288,968July 18, 200608:40x86
Microsoft.crm.application.components.strings.dll3.0.5300.1232719,728July 18, 200608:46x86
Microsoft.crm.application.components.ui.dll3.0.5300.1232220,008July 18, 200608:45x86
Microsoft.crm.application.pages.dll3.0.5300.1232965,464July 18, 200608:47x86
Microsoft.crm.metadataservice.dll3.0.5300.1232158,544July 18, 200608:43x86
Print_dlg.aspxNot Applicable8,816July 16, 200604:07Not Applicable
Syscustutil.jsNot Applicable5,831July 16, 200604:06Not Applicable
Systemsettings.aspxNot Applicable33,171July 16, 200604:06Not Applicable
Microsoft.crm.metadataservice.dll3.0.5300.1232158,544July 18, 200608:44x86

Installation information

Install this hotfix on computers that are running Microsoft Dynamics CRM 3.0 Client and Microsoft Dynamics CRM 3.0 Server.

Prerequisites

No prerequisites are required.

Restart requirement

If you are prompted, restart the computer after you install the hotfix.

Removal information

You cannot remove this hotfix.

MORE INFORMATION

For more information about the terminology that is used to describe Microsoft software updates, click the following article numbers to view the articles in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

887283 Microsoft Business Solutions CRM software hotfix and update package naming standards

To enable the parentaccountid field for bulk editing, you must manually change the .xml file. To do this, follow these steps:
  1. Export customization of Account. To do this, follow these steps:
    1. In Microsoft CRM, click Settings, click Customization, and then click Export Customizations.
    2. Select Account, click More Actions, click Export Selected Customizations on the toolbar, click OK, and then save the exported file as AccountCustom.xml.
  2. In Notepad, open the AccountCustom.xml file, and then search for label description="Parent Account".
  3. Locate the following line in the label description="Parent Account" section of the AccountCustom.xml file:

    <event name="onclick" application="true" active="true"> <event name="onchange" application="true" active="true">

    Change this line so that it appears as follows:

    <event name="onclick" application="true" active="true" BehaviorInBulkEditForm="Enabled"> <event name="onchange" application="true" active="true" BehaviorInBulkEditForm="Enabled">

  4. Save the changed file.
  5. Import the changed AccountCustom.xml file. To do this, follow these steps:
    1. Click Settings, click Customization, and then click Export Customizations.
    2. Select the changed AccountCustom.xml file, and then click Upload.
    3. Select Account, click More actions, and then click Import Selected Customizations.
  6. Publish the customizations. To do this, follow these steps:
    1. Click Settings, click Customization, and then click Customize Entities.
    2. Select Account, and then click Publish on the toolbar.
  7. Open a bulk edit form for Account1 and for Account2.
  8. Click Parent Account look up control.

Modification Type:MajorLast Reviewed:10/9/2006
Keywords:kbHotfixServer kbQFE kbMBSMigrate kbpubtypekc KB913645 kbAudEndUser