A Windows XP Professional-based computer takes a long time to run the startup process after you upgrade from Windows 2000 (913630)



The information in this article applies to:

  • Microsoft Windows XP Professional

SYMPTOMS

You upgrade a Microsoft Windows 2000-based computer to Microsoft Windows XP Professional. However, the upgrade adversely affects the computer's startup process. Specifically, the computer now takes a long time to run the startup process.

CAUSE

This problem occurs when the Shell Hardware Detection service in Windows XP causes the computer to respond very slowly.

WORKAROUND

To work around this problem, follow these steps:
  1. Click Start, click Run, type services.msc in the Open box, and then click OK.
  2. In the Services list, double-click Shell Hardware Detection.
  3. On the General tab, click Manual in the Startup type list.
  4. Click Apply, and then click OK.
  5. On the File menu, click Exit to close the Services snap-in.
Note When you restart the computer after you change the Shell Hardware Detection service startup type to manual, the startup process runs as expected. However, you may then experience the following problems:
  • The Autoplay feature does not work. For example, when you insert a CD into the computer's CD drive, the computer does not automatically play the CD. Or, when you connect an external hard disk to the computer, the computer does not display the contents of the external hard disk.
  • The Fast User Switching feature is unavailable.

Modification Type:MajorLast Reviewed:3/14/2006
Keywords:kbtshoot kbprb KB913630 kbAudEndUser