You may experience network connection problems on a Windows XP SP2-based computer or a Windows Server 2003 SP1-based computer that has more than one network adapter (913522)



The information in this article applies to:

  • Microsoft Windows XP Service Pack 2, when used with:
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Home Edition
  • Microsoft Windows Server 2003 SP1, when used with:
    • Microsoft Windows Server 2003, Standard Edition
    • Microsoft Windows Server 2003, Enterprise Edition

SYMPTOMS

You are using a Microsoft Windows XP Service Pack 2 (SP2)-based computer or a Microsoft Windows Server 2003 Service Pack 1 (SP1)-based computer that has more than one network adapter. If the Windows Firewall is enabled, you may experience network connection problems on this computer. These connection problems occur even if you have added the following items to the Windows Firewall exception list:
  • The application that tries to make the connection
  • The protocol that is used to make the connection
Additionally, information that resembles the following appears in the Firewall log:DateTime DROP Protocol Src-IP Dst-IP Src-Port Dst-Port Size - - - - - - - SENDNote The information is available only if the Firewall log is enabled in the Windows Security Center. Log information is stored in the %systemroot%\Pfirewall.log file.

CAUSE

This problem may occur if the following conditions are true:
  • A multi-homed computer receives a network packet on a network adapter (adapter1).
  • The IP destination of the packet is the IP address of another network adapter (adapter2).
In this case, the response to the network packet may be dropped. The anti-spoofing rule examines each send packet to see whether the sending IP address is bound to the adapter1. The answer packet is dropped because the sending IP address is bound to adapter2.

RESOLUTION

Windows XP

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.PrerequisitesThere are no prerequisites to install this hotfix.Restart requirementYou must restart the computer after you apply this hotfix.Hotfix replacement informationThis hotfix does not replace any other hotfixes.File information The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP Service Pack 2 (SP2)-based versions
File nameFile versionFile sizeDateTimePlatform
Ipnat.sys5.1.2600.2831135,68021-Jan-200601:18x86

Windows Server 2003

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.PrerequisitesTo apply this hotfix, you must have Windows Server 2003 Service Pack 1 (SP1) installed on the computer.Restart requirementYou must restart the computer after you apply this hotfix.Hotfix replacement informationThis hotfix does not replace any other hotfixes.File information The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Ipnat.sys5.2.3790.2745103,42412-Jul-200610:21x86
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Ipnat.sys5.2.3790.2745156,16012-Jul-200617:34x64
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Ipnat.sys5.2.3790.2745350,20812-Jul-200617:34IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:9/18/2006
Keywords:kbfix kbbug kbQFE kbhotfixserver kbpubtypekc KB913522 kbAudITPRO