Error message when you try to make a remote connection to the registry of a Windows-based computer from a Windows Server 2003 SP1-based computer: "Access denied" (913327)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

When you try to make a remote connection to the registry of a Microsoft Windows-based computer from a Microsoft Windows Server 2003 Service Pack 1 (SP1)-based computer, you receive the following error message:
Access denied
This issue may prevent you from using the following programs to deploy agents or clients:
  • Microsoft Systems Management Server (SMS) 2003 Service Pack 1 (SP1)
  • The original release version of SMS 2003
  • SMS 2.0
  • The original release version of Microsoft Operations Manager (MOM) 2005

CAUSE

This issue occurs because of security changes that are included in Windows Server 2003 SP1.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must be running Windows Server 2003 SP1 to install this hotfix.

Note x64-based versions of Windows Server 2003 do not require this service pack.

Restart requirement

You must restart the computer after you apply this hotfix. Also, a restart is required after you make the registry key change that is described in the "To enable the hotfix" section.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Advapi32.dll620,03211-Jan-200603:24x86SP1SP1QFE
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Advapi32.dll1,051,13611-Jan-200603:04x64SP1SP1QFE
Wadvapi32.dll620,03211-Jan-200603:04x86SP1WOW

To enable the hotfix

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.
To enable the hotfix after you install it, add the DontUseSecureNPForRemote entry to the following registry subkey, and then set this entry to a value of 1:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RemoteRegistry\Parameters

To do this, follow these steps:
  1. Click Start, click Run, type regedit in the Open box, and then click OK.
  2. Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RemoteRegistry\Parameters

  3. On the Edit menu, point to New, and then click DWORD Value.
  4. Type DontUseSecureNPForRemote, and then press ENTER.
  5. Right-click DontUseSecureNPForRemote, and then click Modify.
  6. In the Value data box, type 1, and then click OK.
  7. On the File menu, click Exit to exit Registry Editor.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

The issue that is described in the "Symptoms" section may affect programs that use the WnetConnection2 function to connect to a Windows-based computer from a Windows Server 2003 SP1-based computer. Specifically, this issue may occur when the following conditions are true:
  • The WnetConnection2 function uses an alternative set of credentials to connect to the IPC$ share.
  • The WnetConnection2 function takes this action before it calls the RegConnectRegistry function.
For more information about terminology that Microsoft uses to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:8/29/2006
Keywords:kbHotfixServer kbBug kbfix kbQFE kbWinServ2003preSP1fix kbpubtypekc KB913327