FIX: The latest report in the archive is printed instead of the snapshot of the archived report in SQL Server 2000 (913314)



The information in this article applies to:

  • Microsoft SQL Server 2000 Personal Edition
  • Microsoft SQL Server 2000 Developer Edition
  • Microsoft SQL Server 2000 Enterprise Edition
  • Microsoft SQL Server 2000 Standard Edition

BUG #: 217 (SQL Hotfix)
Microsoft distributes Microsoft SQL Server 2000 fixes as one downloadable file. Because the fixes are cumulative, each new release contains all the hotfixes and all the security fixes that were included with the previous SQL Server 2000 fix release.

SUMMARY

This article describes the following about this hotfix release:
  • The issues that are fixed by the hotfix package
  • The prerequisites for installing the hotfix package
  • Whether you must restart the computer after you install the hotfix package
  • Whether the hotfix package is replaced by any other hotfix package
  • Whether you must make any registry changes
  • The files that are contained in the hotfix package

SYMPTOMS

When you try to print a snapshot of an archived report in Microsoft SQL Server 2000, the latest report in the archive is printed instead of the snapshot of the archived report. This problem occurs when you click Print on the report.

For a list of all publicly released SQL Server 2000 post-Service Pack 4 hotfixes, click the following article number to view the article in the Microsoft Knowledge Base:

894905 Cumulative list of the hotfixes that are available for SQL Server 2000 SP4

CAUSE

This problem occurs because SQL Server 2000 Reporting Services does not pass the history ID of the archived report to the print control. By default, when the print control tries to print a report and no history ID is provided, the latest report in the archive is printed.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next SQL Server 2000 Reporting Services service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To apply this hotfix, you must have SQL Server 2000 Reporting Services Service Pack 2 (SP2) installed on the computer.

Restart information

You do not have to restart the computer after you apply this hotfix.

Registry information

You do not have to change the registry.

Hotfix file information

This hotfix contains only those files that are required to correct the issues that this article lists. This hotfix may not contain all the files that you must have to fully update a product to the latest build.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTime
Microsoft.reportingservices.diagnostics.dll8.0.1050.0270,33613-Jan-200613:45
Reportingservices.csvrendering.dll8.0.1050.057,34413-Jan-200613:45
Reportingservices.diagnostics.dll8.0.1050.0270,33613-Jan-200613:45
Reportingservices.excelrendering8.0.1050.0364,54413-Jan-200613:45
Reportingservices.htmlrendering.dll8.0.1050.0389,12013-Jan-200613:45
Reportingservices.imagerendering8.0.1050.0262,14413-Jan-200613:45
Reportingservices.processing.dll8.0.1050.01,331,20013-Jan-200613:45
Reportingservicesnativeserver.dll2000.80.1050.048,64013-Jan-200613:45
Reportingserviceswebserver.dll8.0.1050.0503,80813-Jan-200613:45
Rswebuserinterface.dll8.0.1050.0770,04813-Jan-200613:45

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

After you apply this hotfix, Reporting Services passes the history ID to the print control.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbBug kbfix kbtshoot kbQFE kbhotfixserver kbpubtypekc KB913314 kbAudITPRO kbAudDeveloper