An RPC client cannot connect to an RPC server that is running Windows Server 2003 SP1, and event ID 180 is logged (913184)



The information in this article applies to:

  • Microsoft Windows Server 2003 SP1

SYMPTOMS

Consider the following scenario. A remote procedure call (RPC) server is running Microsoft Windows Server 2003 Service Pack 1 (SP1). This RPC server responds to a security request from an RPC client. Specifically, the RPC server responds by sending a callback that contains a data set that is larger than 64 kilobytes (KB). In this scenario, the RPC client cannot connect to the RPC server. Additionally, event ID 180 is logged in the Application log.

CAUSE

This problem occurs when an RPC exception is generated on a computer that is running an instance of Microsoft Dynamics AX Application Object Server (AOS). For more information about RPC exceptions, visit the following MSDN Web site:

RESOLUTION

Update information

The following files are available for download from the Microsoft Download Center:
Release Date: April 18, 2006

For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to obtain Microsoft support files from online services

Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.

Prerequisites

You must have Windows Server 2003 SP1 installed to apply this update. Apply this update only to computers that are running instances of AOS.

Restart requirement

You must restart your computer after you apply this update.

Update replacement information

This update does not replace any other updates.

File information

The English version of this update has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Rpcrt4.dll5.2.3790.2630643,07201-Feb-200607:22x86SP1SP1QFE

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbRPC kbHotfixServer kbWinServ2003preSP2fix kbBug kbfix kbQFE kbpubtypekc KB913184 kbAudITPRO