Problems that you may experience when you use the SIS file system filter in Windows Storage Server 2003 R2 (913109)



The information in this article applies to:

  • Microsoft Windows Server 2003 SP1, when used with:
    • Microsoft Windows Storage Server 2003 R2

SYMPTOMS

When you use the Single Instance Storage (SIS) file system filter in Microsoft Windows Storage Server 2003 R2, you may experience the following problems:
  • On a computer that is under a heavy load, the SIS Groveler service processes file updates very slowly. This may cause the Groveler service to never catch up if the system continues to work under a heavy load over a long period.
  • On a memory-constrained computer that is under a heavy load, the SIS file system filter may cause the computer to stop responding.
  • On a computer that has other file system filters installed together with the SIS file system filter, you may notice that the computer stops responding after you start the computer.

CAUSE

These problems occur when the following conditions are true:
  • By default, the Groveler service works in background mode with low priority. In this mode, the Groveler service can process only a certain number of NTFS file system changes before it backs off. If the incoming rate of changes to the file system exceeds the number of changes that the Groveler service can process, and if this rate occurs over an extended time, the Groveler service may not catch up. At some point, an NTFS file system journal wrap will occur. This journal wrap will cause the Groveler service to miss one or more NTFS file system changes. Missing these changes will cause the Groveler service to rescan the volume. Rescanning the volume will put even more load on the computer. The Groveler service also has a foreground mode. This foreground mode will process NTFS file system changes until it has completed them all. However, the Groveler service cannot currently put itself in foreground mode.
  • The SIS file system filter may cause the computer to stop responding if a work item is paged to the hard disk on a computer that is under a heavy load.
  • Interoperability issues between the SIS file system filter and other file system filters that are used on the computer may cause the computer to stop responding.

RESOLUTION

Update information

The following files are available for download from the Microsoft Download Center:

Windows Server 2003:

DownloadDownload the Update for Windows Server 2003 package now.

Windows Server 2003 for Itanium-based Systems:

DownloadDownload the Update for Windows Server 2003 for Itanium-based Systems package now.

Windows Server x64 Edition:

DownloadDownload the Update for Windows Server x64 Edition package now.

Release Date: March 28, 2006

For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to obtain Microsoft support files from online services

Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.

Prerequisites

The x86-based versions of Windows Server 2003 and Itanium-based versions of Windows Server 2003 require Windows Server 2003 Service Pack 1 (SP1). For more information about how to obtain Windows Server 2003 Service Pack 1, click the following article number to view the article in the Microsoft Knowledge Base:

889100 How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this update.

Update replacement information

This update does not replace any other updates.

File information

The English version of this update has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Grovel.exe5.2.3790.263383,45604-Feb-200601:38x86SP1SP1GDR
Sis.sys5.2.3790.263372,19204-Feb-200601:38x86SP1SP1GDR
Grovel.exe5.2.3790.263383,45604-Feb-200602:06x86SP1SP1QFE
Sis.sys5.2.3790.263372,19204-Feb-200602:06x86SP1SP1QFE

Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Grovel.exe5.2.3790.2633248,32006-Feb-200608:47IA-64SP1SP1GDR
Sis.sys5.2.3790.2633232,96006-Feb-200608:47IA-64SP1SP1GDR
Grovel.exe5.2.3790.2633248,32006-Feb-200608:41IA-64SP1SP1QFE
Sis.sys5.2.3790.2633232,96006-Feb-200608:41IA-64SP1SP1QFE

Windows Server 2003 and Windows XP, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Grovel.exe5.2.3790.2633146,94403-Feb-200615:23x64SP1SP1GDR
Sis.sys5.2.3790.2633109,56803-Feb-200615:23x64SP1SP1GDR
Grovel.exe5.2.3790.2633146,94403-Feb-200615:18x64SP1SP1QFE
Sis.sys5.2.3790.2633109,56803-Feb-200615:18x64SP1SP1QFE

WORKAROUND

To work around these problems in Microsoft Windows Storage Server 2003 R2, you can use the Sisadmin.exe tool to put the Groveler service into foreground mode. However, the Groveler service runs in foreground mode only until it processes all changes. After the Groveler service processes all changes, it puts itself back in background mode. Therefore, you must periodically put the Groveler service in foreground mode.

Note The Sisadmin.exe tool is unavailable in other versions of Windows.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about SIS and the Groveler service, click the following article number to view the article in the Microsoft Knowledge Base:

299726 A description of the functions of the Single Instance Storage Filter and the Groveler service

For more information about standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbQFE kbHotfixServer kbHotfixRollup kbWinServ2003SP1fix kbWinXP64Bit2003sp1fix kbBug kbfix kbpubtypekc KB913109 kbAudITPRO